LAN/WLAN slowing to a halt when accessing NC via client over domain


Thanks for helping out users! I have following

When I’m in my LAN/WLAN (Gigabit) and want to sync my files with the nextcloud-client via to my server, following happens when I start the client: In the beginning (2 seconds) speed is as expected and then it gets slower until it stalls. I never get past max. 20 MB sometimes less. It also seems to block the whole bandwith as netflix becomes unwatchable due “no” bandwith. When I kill the Client - within seconds everything goes back to normal in the LAN/WLAN.


  • When I sync from outside LAN with client over everything works just fine.
  • When I use my.hom.e.ip:port to sync. Everything works just fine.
  • Access via browser could be faster but is as expected when using domain instead of local IP

Hardware: zbox ci327 nano 4GB RAM

  • Hostsystem: ubuntu server 18.04
  • Docker Client Version: 18.09.8
  • Server: Docker Engine Version: 18.09.8
  • Traefik as reverse proxy (V1.7.12) with letsencypt
  • nc16.0.3
  • latest nc-clients

Already tried
There are several threads about bruteforce detection. I already

  • wipped the oc_bruteforce_attempts in mariadb
  • added all IPs on my dhcp-list to the whitelist of the bruteforce app
  • added trusted domains in config.php
  • restarted the whole system several times (after each change more or less)

Any ideas what might cause the Problem? Please let me know if you need further info.

Thank you

When you’re connecting to your NC instance - and I assume, that you don’t have an internal DNS server, which directs your client to the local IP of your NC instance, but instead routes all traffic though your internet gateway. A surprisingly high number of SOHO router have issues with such a setup.

Try setting up an internal DNS resolver, which has the IP for your NC instance point directly to the internal address.

Or just added your Local IP to the hosts file of your local PC. E.g.:

This will drive to route your traffic in local network only. Issue: it dos not work when you will take you laptop with you and access your NC via internet. You need to comment this line in this case.

Actually, I’d only do that for testing purposes - having to manually change your local hosts file is cumbersome and error-prone.

For local PC it is not worse as getting up local DNS resolver.

More than likely that is his problem. Commercial firewalls typically won’t even allow such a connection.

If you access Nextcloud by using the outside IP instead of the inside IP, does that reproduce the problem? Does it even connect?

Another workaround you can try is adding it to the client’s hosts file with the inside IP. Does that fix it?

Hi and thank you to all of you for your suggestions and help.

Accessing nextcloud is accessible via browser using the domain. I have not yet tested “heavy duty” data transfer to see if it creates the original Problem again.

For now I have opened another port on the nextcloud-docker-container for LAN use - - > works fine.

The plan for now is the following:
I have my ISP changing anyway next week. Then I get a new router which allows altering DNS-Server. I intend to set up pihole and point the Router to pihole for DNS. In pihole I can setup manual entries that apply to all devices - AFAIK… This should solve the problem as well, now that I know what it mostlikely is.

I’ll let you know how it worked out.

The Answer is: use a router that can handle it! My new ISP sent me a Fritzbox as Router - voilà: all problems gone… without me doing anything! So budy was right.

1 Like

FritzBox is good, but if you need to pay for it, it is quite expensive, as alternative you can put ether dd-wrt, or open-wrt on yout older Router and get more advanced features.