La Connexion avec le serveur a été perdue

Bonjour à tous.

Mon serveur Nextcloud tourne depuis deux ans sans difficulté majeur.

Cependant, depuis trois jour, dans l’interface web, voici le message que j’ai : “La Connexion avec le serveur a été perdue”

et impossible de voir les fichiers en page web. La synchro par l’app nc fonctionne pas non plus après plus de vérification.

Dans la partie “Vue d’ensemble” et “Avertissements de sécurité & configuration”, j’ai ce message : “Votre serveur web n’est pas encore correctement configuré pour la synchronisation de fichiers parce que l’interface WebDAV semble ne pas fonctionner.”

Qu’est-ce qui a changé depuis ??? Rien touché, rien changé !!!

Je suis en peu en peine sur ce coup. Merci de votre aide et orientation.

Bonjour @Cyrill, je ne connait pas trop de solution pour vous aider la dessus. De nombreux topic pourrait vous aider ( rechercher dans les topics anglais ).

Peut être que l’une des 2 commandes peut vous aider : ( modifier le chemin de votre répertoire nextcloud)
sudo -u www-data php /var/www/nextcloud/occ maintenance:update:htaccess
sudo -u www-data php /var/www/nextcloud/occ maintenance:updaterepair

Bonjour,

Merci du coup de main.

Je viens de tester les deux commandes, sans succès.

Pour plus d’info sur ce que j’ai testé:
J’étais sous Lubuntu 20.04 et Nextcloud 24.
J’ai vérifié que ce ne venais pas de mon reverse-proxy en le bypassant: toujours pareil;
mise à jour à NC 24.0.1: toujours pareil;
mise à jour à Lubuntu 21.10 : toujours pareil;
création d’une vm avec nextcloud selon ce tuto : toujours pareil.

Bon, je m’arrache les cheveux…

Je comprend pas grand chose au truc.

Mais je crois que je suis embêter par mon proxy-reverse…

Le problème venait du reverse proxy mis à jour sous Kubuntu 22.04. Merci du coup de main.

1 Like

Bonjour
@Cyrill pourrais tu m’en dire plus sue la conf de ton nginx stp ? J’ai exactement le même pb et je n’arrive pas à m’en sortir.
Merci :smiley:

Bonjour,

Perso je suis revenu sur un proxy reverse en 20.04.

Dès que je mets plus récent, ça bug.

Quelles informations souhaites-tu? Côté serveur reverse proxy ou côté serveur nextcloud?

Des infos plutôt côté reverse proxy
Je suis sur une Debian10 avec une version nginx 1.14.2
J’ai un doute sur la config du vhost, la voici

server {

listen 80;
server_name nextcloud.xxxx.fr;
return 301 https://nextcloud.xxxx.fr$request_uri;	

}

server {

listen 443;
server_name nextcloud.xxxx.fr;
ssl on;

ssl_certificate /etc/ssl/certs/pubInter-xxxx4-Certificate.cer;
ssl_certificate_key /etc/ssl/private/priv-xxxx.fr.key;
keepalive_timeout 70;

access_log on;
access_log /var/log/nginx/nextcloud.access.log;

if ($request_method !~ ^(GET|HEAD|POST)$ ) {
return 444;
}

location / {
proxy_pass https://xxx.xx.xx.xx;
include proxy_params;
add_header Front-End-Https on;

proxy_headers_hash_max_size 512;
proxy_headers_hash_bucket_size 64;
proxy_redirect off;
proxy_max_temp_file_size 0;

}

location /.well-known/carddav {
return 301 /nextcloud/remote.php/dav;
}

location /.well-known/caldav {
return 301 /nextcloud/remote.php/dav;
}

error_page 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 500 501 502 503 504 505 506 507 /error.html;

location = /error.html {
root /usr/share/nginx/www;
}
}

Je précise que le serveur fonctionne. C’est uniquement quand je vais dans “Tous les fichiers” que j’ai un message d’erreur “La connexion au serveur a été perdue”
NB : sans le nginx, en reverse proxy et avec mon nextcloud dans mon domaine cela fonctionne

Donc j’ai dans le fichier proxy_params

proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;

Puis j’ai dans le fichier domaine.fr.conf (dans sites-enabled / available)

server {
server_name domaine.fr;

location / {
    proxy_pass https://xx.xx.xx.xx;
    proxy_set_header    Host $host;
    proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_connect_timeout 30;
    proxy_send_timeout 30;
}


listen                  443 ssl http2; # managed by Certbot
ssl_certificate         /etc/letsencrypt/live/domaine.fr/fullchain.pem; # managed by Certbot
ssl_certificate_key     /etc/letsencrypt/live/domaine.fr/privkey.pem; # managed by Certbot
include                 /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

ssl_ecdh_curve          secp384r1; #par moi

}
server {
if ($host = domaine.fr) {
return 301 https://$host$request_uri;
} # managed by Certbot

server_name domaine.fr;
listen 80;
return 404; # managed by Certbot

}

Tout le même mauvais fonctionnement que moi.