Kein zugriff mehr auf Nextcloud (weder Lokal noch ├╝bers Internet) nach abgelaufenem Zertifikat

Hallo Zusammen,

ich bin gerade mit meiner Nextlcoud am verzweifeln. Vor ein paar Tagen musste ich ein Backup zur├╝ckspielen. Da lief die Nextcloud noch ganz normal, doch pl├Âtzlich kann ich werder lokal noch ├╝bers Internet auf die Nextcloud zugreifen. Meine Nextcloud l├Ąuft auf einem LXC mittels Proxmox.

Vermutlich ist das Problem, dass das SSL Zertifikat abgelaufen ist, da ich sie aber werder lokal noch sonst irgendwie erreiche, kann ich auch nicht das Zertifikat erneuern. Lets Encrypt muss ja von au├čen ├╝ber http zugreifen k├Ânnen um das Zertifikat zu erneuern. Wie bekomme ich es jetzt hin, dass ich erstmal wieder lokal ├╝ber http Zugriff erhalte? Meine Vermutung dass das Zertifikat abgelaufen ist r├╝hrt daher, dass ich eine Mail von LetsEncrypt bekommen habe, dass das Zertifikat demn├Ąchst abl├Ąuft.

Wenn ich in Firefox http://192ÔÇŽ eingebe werde ich komischerweise auch immer auf https://meineDomain.de umgeleitet. Es erscheint dann die Meldung ÔÇťPR_CONNECT_RESET_ERRORÔÇŁ. Ich meine mich daran zu erinnern mal eingestellt zu haben, dass die Nextcloud eine Verbindung ├╝ber HTTPS erzwingt. Nur dumm, wenn das SSL-Zertifikat abgelaufen ist :rofl:

Mein erster Plan war also der, das ganze wieder so zur├╝ck zu bauen, dass die Nextcloud keine SSL Verbindung mehr erzwingt, um dann das SSL Zertifikat erneuern zu k├Ânnen. Hierzu habe ich meine Konfigurationsdateien bearbeitet.

Meine nextcloud.conf in apache2/sites-available:

<VirtualHost *:80>
     ServerAdmin master@domain.com
     DocumentRoot /var/www/nextcloud/
     ServerName meineDomain.de
     ServerAlias 192..........


     Alias /nextcloud "/var/www/nextcloud/"
     <Directory /var/www/nextcloud/>
        Options +FollowSymlinks
        AllowOverride All
        Require all granted
          <IfModule mod_dav.c>
            Dav off
          </IfModule>
        SetEnv HOME /var/www/nextcloud
        SetEnv HTTP_HOME /var/www/nextcloud
     </Directory>
     ErrorLog ${APACHE_LOG_DIR}/error.log
     CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Zus├Ątzlich habe ich noch im Ordner apache2/sites-available eine Datei nextcloud-le-ssl.conf und default-ssl.conf

In dem Verzeichnis nextcloud/config/config.php steht folgendes:

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => '192...........',
    1 => 'meineDomain.de',
  ),
  'datadirectory' => '/home/data/',
  'dbtype' => 'mysql',
  'version' => '23.0.0.10',
  'overwrite.cli.url' => 'http://192............/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user',
  'dbpassword' => 'xxxxxxxxxx',
  'installed' => true,
  'maintenance' => false,
  'default_phone_region' => 'DE',
  'theme' => '',
  'loglevel' => 2,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '127.0.0.1',
    'port' => xxxxx,
    'password' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
    'timeout' => 0.0,
  ),
  'updater.release.channel' => 'stable',
  'log_type' => 'file',
  'logtimezone' => 'Europe/Berlin',
  'logfile' => '/var/log/nextcloud.log',
  'syslog_tag' => 'Nextcloud',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'mail',
  'mail_domain' => 'xxxxxx.de',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => 'xxxxxxxxxxx',
  'mail_smtpport' => 'xxx',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'xxxxxxxxxxxxxxxxx',
  'mail_smtppassword' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
);

In der hosts datei steht das:


127.0.0.1       localhost
127.0.0.1       nc1.local
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters
# --- BEGIN PVE ---
192................... nc1.local nc1
# --- END PVE ---

Leider funktioniert mit den genannten Konfigs nicht. Warum? Ich werde nachwievor immer auf https umgeleitet. Was habe ich ├╝bersehen?

Hoffe auf eure Hilfe. Viele Gr├╝├če

Problem erledigt. Es lag an der nextcloud-le-ssl.conf. Da ist alles was mit ssl zu tun hat gespeichert und hat letztendlich daf├╝r gesorgt, dass ich immer auf ssl umgeleitet wurde

Auch wenn du dein Problem gel├Âst hast:

An deiner Stelle w├╝rde ich intern und extern immer den gleichen Zugriff https://meineDomain.de verwenden. Das sollte eigentlich auch von innen problemlos funktionieren und auch keine Nachteile, sondern nur Vorteile bringen. So kannst du z. B. in einer m├Âglichen Smartphone-App immer die gleiche URL verwenden.

Evtl. sind Änderungen am Router notwendig.
Stichworte Hairpinning und NAT Loopback

Aber vielleicht funktioniert der Zugriff von innen ja auch schon entsprechend.

Danke dir f├╝r den Hinweis. Leider kann das meine Fritzbox Cable 6490 nicht :frowning:
Von dem her geht momentan alles ├╝bers Internet. Irgendwie schon d├ĄmlichÔÇŽ

Naja. Wenn du intern deine weltweite IP-Adresse aufrufst (z. B. DynDNS), dann gehen die Daten nur bis zur Fritzbox und nat├╝rlich nicht zu deinem Provider und wieder zur├╝ck. Es ist eher eine Frage, ob es ├╝berhaupt funktioniert, dass du intern den weltweiten Namen und damit die ├Ąu├čere Schnittstelle deiner Fritzbox erreichen kannst.