Kann keine Dateien auf lokale SSD verschieben oder löschen

Hallo zusammen,

bin gerade am verzweifeln. Suche seit Stunden unerbittlich nach einer Lösung fĂŒr folgendes Problem:

Hab mir einen NextCloudPi eingerichtet und eine SSD Festplatte damit verbunden bzw. eingebunden. Über SSH ist es mir möglich Dateien zu erstellen und auf dieser zu speichern, welche auch im Webinterface angezeigt werden. Leider ist es mit nicht möglich diese ĂŒber’s Webinterface wieder von der SSD zu löschen, geschweige denn Ordner oder Dateien auf diese zu verschieben/kopieren. Bekomme immer nur die Nachricht “XXXXX konnte nicht verschoben werden” oder “XXXXX konnte nicht gelöscht werden”.

Ich weiß nicht wo ich ansetzen soll.
In den Einstellungen unter “Persönlich → Externe Speicher” wird die Platte angezeigt, doch sobald ich auf den Haken rechts neben Konfiguration klicke, erscheint links neben Ordnername ein rotes Ausrufezeichen. Klicke ich auf dieses, wird es ein grĂŒner Haken.
Kann da auch nichts weiter verÀndern, weil ich angeblich keine Rechte habe obwohl ich Admin bin.

Wenn noch mehr relevante Infos erwĂŒnscht sind, werde ich diese natĂŒrlich mitteilen.

Ich danke euch schonmal im Voraus!!

Hi,

check mal ob es nach einem:

sudo -u www-data php /path/to/nextcloud/occ files:scan --all

noch immer probleme macht.

Siehe hier:

@Larsito
Wenn der Tipp von @sambilanet nicht hilft schau auch noch, ob die Dateirechte korrekt sind. Korrekter Benutzer:Gruppe meist www-data:www-data und die Zugriffsrechte.

Allet klaro! Ich werde eure LösungsvorschlÀge ausprobieren, sobald der Raspberry wieder im Netzwerk ist.
Ey, keine Ahnung was da wieder schief gelaufen ist, aber habe den gestern ausgemacht, gerade eben wieder gestartet und einfach die Netzwerkverbindung futsch :laughing:

Vielleicht bekommt dein Pi die IP-Adresse dynamisch ĂŒber DHCP. Vielleicht hat er nur eine neue IP-Adresse bekommen. Du kannst mal auf dem Router nachschauen, wie die IP-Adresse ist. Auch kannst du sie am Router oft manuell konfigurieren.

Problem hat sich gelöst, hab die “wpa_supplicant.conf” neu aufgespielt.
Aber dafĂŒr funktioniert die NextCloud nu net mehr đŸ«€
“Internal Server Error”
 War so wĂŒtend in dem Moment, da es sich gerade zu einer Neverending Story entwickelt, und werde heude Abend das NextCloudPi Image erneut flashen.

Die Tutorialvideos sahen so einfach aus :thinking:

Könntest ja auch ein LAN-Kabel verwenden. :wink:
Ich habe kein Pi. Aber lese vielleicht kurz diese Anleitung und trage - falls möglich - eine feste IP-Adresse ein. Ist zwar fĂŒr Debian Stretch aber wird sich wohl nicht viel verĂ€ndert haben.

EIN LAN-KABEL VERWENDEN :exploding_head::exploding_head::exploding_head:
Sobald ich Zuhause bin, kĂŒtt’ da ein LAN-Kabel rein!

Okay, ich lese mir die Anleitung ma durch.
Dankeschön :smiley:

Hier hoffentlich das gleiche Ziel aber leichter zu lesen :slight_smile:
Mir hat das ssh und wifi beim Booten sehr geholfen.