Kalender Anzeige

Hallo Community. Folgendes “Problem” habe ich mit dem Kalender und dessen Anzeige.

Meine Nextcloud liegt bei All-Inkl (shared). Ich hatte Probleme das Update von 19.0.0 auf 19.0.1 zu starten.
Habe in /nextcloud/ die .htaccess.ini mit php_value memory_limit 512M erweitert. Dieser Eintrag ist komischerweise seit dem Update nicht mehr da.
Jedenfalls konnte ich danach das Update starten.
Ebenfalls hatte ich das Verzeichnis /nextcloud/tmp/ gelöscht, da es diesbezüglich zu einer Fehlermeldung beim starten des Updates kam.

Mir ist nach dem Update aufgefallen (ob da ein Zusammenhang mit dem Update vorliegt kann ich nicht genau sagen), das am PC in der Ansicht des Kalenders keine Einträge mehr vorhanden sind.
Vor dem Kalender dreht sich der Kreis permament. Ein deaktivieren und wieder aktivieren der App bringt keinen Effekt.

Am Smartphone (Note10+, sync mit DAVx5) sind alle Einträge da. Auch neue Einträge am Smartphone sehe ich unter Aktivität auf Nextcloud.
Erstelle ich einen neuen Eintrag am PC, wird dieser auch synchronisiert, aber der Eintrag wird in der Übersicht am PC nicht angezeigt.

Ich habe unter Protokollisierung gesehen, dass er das /tmp/ Verzeichnis sucht. Via FTP neues Verzeichnis erstellt. Ohne Erfolg.

Auch das Erstellen eines neuen Kalenders funktioniert, allerdings dreht sich da auch nur der Kreis vor dem Kalendernamen.

Kann mir jemand helfen?! :slight_smile:

Grüße
Marcel

Ich habe hier mal ein wenig gesucht, und ein ähnliches Problem gefunden.

Dort war dies die Lösung:

A little update of the lines to change with this problem. In a previous post I pasted some wrong quoting characters, sry. Here’s the correction.

Edit/Note: - unfortunatley it’s Discourse changing the simple quotes to wrong ones. Please take care of using the right quotes, I don’t know how to tag the right inhere, sorry.

Make sure these settings are replaced in:

vi /var/www/[yourNCdirectory]/3rdparty/sabre/vobject/lib/Recur/RRuleIterator.php

Replace:

$date->setDate($currentYear, 1, 1);
with
$date = $date->setDate($currentYear, 1, 1);

$date->add(new \DateInterval(‘P’ . $byYearDay . ‘D’));
with
$date = $date->add(new \DateInterval(‘P’ . $byYearDay . ‘D’));

$date->sub(new \DateInterval(‘P’ . abs($byYearDay) . ‘D’));
with
$date = $date->sub(new \DateInterval(‘P’ . abs($byYearDay) . ‘D’));

Zum ersten Punkt:
$date->setDate($currentYear, 1, 1);
with
$date = $date->setDate($currentYear, 1, 1);

Das war bei mir genau so.

$date->add(new \DateInterval(‘P’ . $byYearDay . ‘D’));
with
$date = $date->add(new \DateInterval(‘P’ . $byYearDay . ‘D’));
Den Eintrag habe ich erst gar nicht gefunden…

Shared Hoster = Bitte Deinem Hoster um Support bitten.

Niemand von uns hier wird die genauen Einstellungen oder EInschränkungen des Servers wissen, noch kann niemand Dir sagen, was Du für Berechtigungen hast oder nicht hast.

Wenn Dein Hoster keinen Support anbietet, dann spricht das für sich und ich empfehle diesen a) entweder zu wechseln oder b) Dir eine eigene Instanz hochzuziehen sofern das Fachwissen vorliegt.

Vielleicht verstehe ich da was falsch… Aber es ist doch eine Datei in NC. Wie soll der Hoster mir da helfen? Ich denke nicht das es was mit den Einstellungen zu tun hat die ich “global” mache…

Ich hatte bezüglich des Memory_Limit schon gefragt, darauf wurde mir gesagt, ich solle das in der .htaccess.ini eintragen… Da ging es aber lediglich NUR um das Update auf 19.0.1
Ich glaube aber, dass das Problem durch das Update ausgelöst wurde.
:slight_smile:

Also das Darstellungsproblem ist behoben, ich habe cron.php mal ausgeführt. Heute morgen habe ich es mal überprüft, und funktioniert wieder.

cron.php war übrigens nicht der auslöser.
nach der umstellung von http auf https hat es auf allen geräten funktioniert.