Issues with the Nextcloud Website

on in the first story about “You are Nextcloud, too” your link to the forums goes to not

also on the contact page ( it doesn’t seem to like US phone numbers, kept on saying I was missing the country code even after I added the 1- to the front of it.

That’s all I have found so far but I figured I would let you guys know. I am super excited about this and can’t wait for the first release.


@jospoortvliet your blog

I’ve fixed that issue! Any others are welcome.

1 Like

Will “” get an GitHub repository :thinking: @jospoortvliet

Oh, absolutely, we’ve been yelling at each other all day yesterday about overwriting other people’s changes and all that. This should be managed in git, that much is clear :smiley:

And obviously in the open, no reason not to… Worked great for us before, right?


My irony detector seems kinda broken when it comes to this posting… :joy:
Seriously, tho… there will be a github repository, right?

Yes, of course this will be in an open repository! :slight_smile:

There is a massive spelling error on the NextCloud home page Just the first Sentence.
Under “Your next cloud”

Nextcloud is tarted by an experienced team of engineers that has had the vision for years to bring private file sync and share to the next level.
Follow our news page and subscribe to our newsletter to learn more.

I hotpatched this on the server for now but @jospoortvliet needs also to apply the changes manually again to not overwrite them.

Thanks for pointing this out!

fixed. Sorry it took so long, crazy here.

and THANK YOU for reporting, I really appreciate that! You rock, @Josh_Wilson and @Kevin_Burkeland

And @mario-ragucci-sp - yeah, my comment wasn’t ironic, it was totally truthful. I’ve been yelled at, loudly, mostly by @LukasReschke who has to make up for it when we meet next week and set up a github page for the website :wink:

The contact forms should now also work again.

1 Like

from now on, you can do a pull request or file an issue on github :wink:

have a great weekend!


I tried to use the contactform, but i got the error;

We are very sorry, but there were error(s) found with the form you submitted: The organization you entered does not appear to be valid. Please go back and fix these errors.

I already said this on the irc channel and lukas responded to me to send screenshots to him along with the error, so it could be that this has already been fixed. I’m just mentioning this here because i can imagine you guys are very busy at the moment.

Also, the form field is limited to the number of characters, so i would suggest/like enlarging the number of words/text we can send. Or mention a emailadress so i can use my local emailclient.

Thanks for the feedback, Dennis. It should really work now, please, see if you can test it (we don’t mind getting a test email)!

The issue stil existst;
We are very sorry, but there were error(s) found with the form you submitted:
The organization you entered does not appear to be valid.
The phone number you entered does not appear to be valid, did you add a country code like +49?

Please go back and fix these errors.

Strange, it works for me.

You have to enter a valid phone number and a organization/company name, there are sanity checks (organizations can’t be named *(#&$ and phone numbers have no letters etc) so that might be the issue.

What data do you enter?

So I did an update but mistakenly didn’t apply it… Things should work now.

1 Like

so it worked.

I had a few errors on the phone number though;
+31850099999 was allowed
but these weren’t;
+31 (0)85 0099999
+31 85 0099999

obivously i changed the phone number to something non existent for this post.