[Issue] No memory cache has been configured

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.0
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04 Server
Apache or nginx version (eg, Apache 2.4.25): 2.4.41
PHP version (eg, 7.4): 8.0

The issue you are facing:
No memory cache has been configured. To enhance performance, please configure a memcache. After updating the config.php file based on the documentation I am getting internal server error on my web browser.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php $CONFIG = array ( 'instanceid' => 'ochqj5egsph5', 'passwordsalt' => '/DS5RiGtnXUxzaz+zxRhN32PDWOqFx', 'secret' => '7fB7MDDQgVI5SSoNR4duIfNR71RccaOwIvi6q40f0ZpDQuvP', 'trusted_domains' => array ( 0 => '', 1 => '', ), 'default_phone_region' => 'IN', 'datadirectory' => '/var/www/nextcloud/data', 'dbtype' => 'mysql', 'version' => '23.0.0.10', 'overwrite.cli.url' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'nextcloud', 'dbpassword' => '', 'installed' => true, 'filelocking.enabled' => true, 'memcache.local' => '\\OC\\Memcache\\Redis', 'memcache.locking' => '\\OC\\Memcache\\Redis', 'redis' => array ( 'host' => '127.0.0.1', 'port' => 6379, ), ); The output of your Apache/nginx/system log in `/var/log/____`: ``` PASTE HERE ```

Is the cache configured correctly and have the packages-/modules needed (redis-server, php-redis) been installed?

https://docs.nextcloud.com/server/23/admin_manual/configuration_server/caching_configuration.html

Also, the config.php should contain the entries according to the doc:

  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
  ),