iOS Number upload error

Hi,
since a few day I´m not able to save numbers files which i´ve changed in iOS Numbers APP. Can´t really say since when or since which Server Version. Not all files, just a few, but these few are very important for me. iOS Nextcloud Client, MacOS Finder, iOS Numbers, MacOS Numbers and Web Interface show the new Date of the Change, but the file is the old one without Changes.

I´m using iOS Client 2.23.3 and Server Version 15.0.5 on hosted server. No errors in Servers Logfile. Installed Client and Server completely new. Problem still exists.

Perhabs this Problem exists if i rename a file or move it to another directory. have tried it with a new file and the Problem ist there if i try to change the table more than twice. First change worked.
Here is a Picture of the Error in iOS NumbersScreenshot

Tested it with ios owncloud client 3.8.1 … seems to work fine. Integration is not as nice as nextcloud client. Think I found a workaround, but not really a solution.

Seems to be a problem with the cache of IOS Client. Cleaning the cache in the preferences solved the problem.

But i have to clear cache once a week to keep it running and not to show the error as written above. Any suggestions, need help.