iOS KeePass Client(s) unable to "copy to" / save keepass password file to NextCloud

Just migrated to NextCloud on a FreeNAS server over the holiday. I’m moving from a Synology Box that used SynologyDrive for the personal cloud functions.

I managed to get everything transferred, users setup, platforms installed (e.g. iOS, Mac, Linux, Windows, etc) and everything seems to function well from the Desktop perspective, and when passively receiving to the iOS platform.

Then, when I changed my KeePass database on my iOS device and attempted to upload it to the NextCloud server, it would not work. I use a program called KyPass, and I tried to use StrongBox (another KeePass compatible program). Both programs failed with a similar issue.

I tried to COPY-TO NextCloud, I can navigate to the folder where I keep my keepass file, but the file I am attempting to upload DOES NOT appear in this window. (I mention this, as when duplicating this process with PAGES, I see the document I am going to upload)
Any way, when I click SAVE on the upload window that DOES NOT have the password file listed, the screen flashes quickly, and goes back to the password manager…

End result is NO FILE uploaded to NextCloud.

I’m trying to understand what program is at fault here… e.g. NextCloud, KyPass / StrongBox, or iOS…

Any comments, help, suggestions, etc. are greatly appreciated.