IOS Can't upload/download on mobile network

Nextcloud version: 12
Operating system and version: Ubuntu 16.04
Apache or nginx : Apache

Is this the first time you’ve seen this error?: No

Can you reliably replicate it? Yes

The issue you are facing:
Using IOS NextCloud application, I can’t upload or download any files while on T-Mobile network. I can navigate the structure of my file system and see recent changes. If I clear cache, all thumbnails will download and display just fine. When I click on a photo, it just gets queued up and wont download. There aren’t any errors displaying server side nor do any error messages appear on my phone.

If I connect the phone to Wi-Fi all works correctly. No issues, its just when I’m on a mobile network.

If I use the browser (safari) from my phone on a mobile network, it works perfectly fine.

Anyone have any ideas of what might be going on? I don’t see anyone else having this issue, so it must be some sort of setup issue. I’ve tried uninstalling and reinstalling the app, still no luck.