iOS can´t share as a link

Hi, i´m using:

Debian 9.6, 64 bits, netinstall;
Kernel, release 4.9.0-8-amd64;
Apache, version 2.4.25;
PHP, version 7.0.33;
Mariadb, version 10.1.37;
Nextcloud, version 15.0.0;
iOS. version 12.0;
Nextcloud App for iOS: 2.22.7;

When I select to share folders and files as link in iOS app, show this “error”:

In logs, don´t any error. Works fine when i share with Android APP or Web browser.

I have on public IP, and i use redirect in another apache server link this:

<VirtualHost *:80>
Proxypass / timeout=300
ProxypassReverse / timeout=300

And in server where run nextcloud:

<VirtualHost *:80>
DocumentRoot /var/www/html/nextcloud
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

<Directory /var/www/html/nextcloud/>
Options +FollowSymlinks
AllowOverride All

Dav off

SetEnv HOME /var/www/html/nextcloud
SetEnv HTTP_HOME /var/www/html/nextcloud

Anybody knows how solve this problem?

I got the same problem on an new Ubuntu 18.02, Apache2, MariaDB, php7, NextCloud15.02 - with Android it is possible to share and create public links. In my opinion it is an App Bug? Anybody got an solution or workaround?

Hello again, I found an workaround for it.

Login as Admin (WebBrowser) - Settings - Administration - Share and disable the Option “Force Passwort” in the Share Link section.

Then it works on iOS but you will get unsecure (no password) link maybe :wink: