iOS App won't work after update from 14.0.3. to 14.0.4

Hello together,

I have already searched the forum and tried several solutions. Unfortunately always without success.

I have updated from 14.0.3 to 14.0.4. Since then the following security & setup warnings are displayed.

Your web server is not set up correctly to resolve "/.well-known/caldav". You can find more information in the documentation.

Your web server is not configured correctly to resolve "/.well-known/carddav". You can find more information in the documentation.

I must confess, I haven’t worked with the iOS App yet. Now I would like to give my users the possibility to use the app.

Nextcloud is installed on a Ubuntu server 16.04 with Apache2.

Installation directory is /var/www/html/nextcloud

.htaccess-file contains:
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP_USER_AGENT} DavClnt
RewriteRule ^$ /remote.php/webdav/ [L,R=302]
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^\.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^\.well-known/host-meta\.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.*) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
RewriteCond %{REQUEST_URI} !^/\.well-known/(acme-challenge|pki-validation)/.*
RewriteRule ^(?:\.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

According to the documantation this should work.

Anybody got an idea?

Thanks and greetings

Did you read this?

Hi eehmke,
yes, I read this. I mentioned it in my post above.
But it doesn’t work.

by the way: I got another nextlcoud server running. And there it works. There I installed version 14.0.4 directly. Settings seems to be equal.


after updating to version 15.0.4 iOS App still does not work. All other server which were directly installed with version 14.0.4 or higher are working fine.

Your description is really vague. Are there any messages displayed if you access “Settings > Management > General Settings”? How are you accessing the server, over the Internet?
Are you able to access the server using the web gui from your mobile phone? Does it show
a certificate error? What url are you trying to use to access the Nextcloud ressources?
Could you see any messages in the log files, etc., etc.?

with the app I’m just able to enter the server address. After that it takes a few seconds until a timeout message appears. Web gui works fine from computer and mobile. No cert errors. I admittedly haven’t looked in the logs yet. Shame on me.

checked the logs with tail command, but can’t find entry for my connection.
I checked nextcloud.log, apache access.log. Any other suggestions to check?