iOS app integration with the Files app

I have been using the iOS client for over four months without any problems. However, since a week or so, the integration with the native Files app on iOS is completely broken/unusable for me. I don’t know what has changed except the new iOS updates, but I am unable to view or open any file(s) in the files app. I have tried resetting the application, deleting and re-installing both the nextcloud and files app, but nothing works. Tapping on a file in the Files app just opens a black screen with some meta-info about the file and its size (jpeg, pdf, mp4 etc with the files size). Nothing else, no thumbnails, nothing. The cloud icon that used to be displayed next to each file showing whether the file is on device or on remote location is gone.

The nextcloud app itself is working as it did. I tried disabling and enabling the files app integration from the nc client settings too. I have a one drive that does not have any such problems so I don’t think its a problem with the files app.

EDIT: iOS 13.1.2, iPhone 7, Nextcloud, server 16.0.4

Same problem over here, Nextcloud in Files has stopped working entirely. OneDrive and Dropbox both work in Files, though curiously OneDrive won’t store files offline either and the cloud icon is missing. Dropbox works fine though.

Ok so I sort of figured out what happened. After the latest nextcloud app update, I switched the “disable local cache” from the advanced settings in the app. And then nothing on nextcloud opened or generated a preview in the files app. I disabled the “disable local cache” option today and went through a few files and images in the nextcloud app and then opened those same files from the files app and voila, they opened just fine. However the cloud icon is still missing and I cannot open or view any content on my nextcloud without first opening it in the nextcloud client which I guess stores it in cache and that is what the files app is using to show content in its own view.

iOS 13 and the nextcloud app update came out around roughly the same week so I can’t say whether it is something with the client that needs to be updated or if something changed in iOS 13.