Invalid hash for text apps when upgrading from 19.0.3 to 19.0.9

Nextcloud version 19.0.9
Operating system and version CentOS 7
Apache or nginx version Apache 2.4
PHP version 7.4

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): Y

I updated from the version 19.0.3 to 19.0.9 by using the guide indicate here: Upgrade manually — Nextcloud latest Administration Manual latest documentation

After the upgrade, when i go in adminsettings i find the notification:

Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation. ([List of invalid files…])

When I open the list of invalid files i found the following error:

[text] => Array
    (
        [INVALID_HASH] => Array
            (
                [babel.config.js] => Array
                    (
                        [expected] => 11efbe076d22fbb7018ddad7cc6e9d12927ff86b9242dcc751f3eff7d4a7167580d3b6ed7ebfaa68931991b1b66e534b8a837526cf5bb86dd8a31465ab2ea2c2
                        [current] => c244da1db042cea87a75d6e54d6667866bd3e917089e844c5a40516ce4f4853de92d997e71680f0bd01bab6fda1be08ed9250175d94b5cf954f55e19c149ce29
                    )

I checked the signature of babel.config.js inside /nextcloud/apps/text/appinfo/signature and it is the one started with 11efbe076d22fbb7018ddad7cc6e9d1 so the one expected.
I also checked the signature on the oldest version (19.0.3) and it starts with c244da1db042cea87a75d6e54d666

During the upgrade I copied the following file to the folder with the new installation:

  • config/config.php
  • data/ (the whole folder)
  • apps/ (the whole folder)

Thank you for any suggestion.

For the moment I fixed by avoiding to copy the directory apps/
In the previous installation I installed files_antivirus and richdocuments, for this reason I wanted to copy the folder. But I notice that the command sudo -u apache php occ upgrade install this applications.