Internal Server Error when attempting to open odt file with Collabora/CODE following install

Following the documentation here: I installed CODE on the same server of mine as a nextcloud install (latest version - 13.0.1)

When I attempt to open an odt file, I get the following error:

Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.
Technical details

And ‘route -n’ produces a line with this: U 0 0 0 docker0

While ‘ip route show’ produces lines with the following: dev lo scope link dev docker0 proto kernel scope link src

docker -v produces the following:

~# docker -v
Docker version 17.03.1-ce, build c6d412e

What kind of firewall rules are needed for the host to connect to the docker container, and vice verse?

This appears to me to be a firewall issue, but any help would be appreciated.

I’ve been reading up through the various similar threads regarding the errors that I’m getting.

It seems that there may be a Curl problem? Or not. But there also seems to be an issue where many people say (at least on ubuntu or debian stretch) requires a change from AUFS to overlay2. I’m apparenlty configured with my Docker CE to use the btrfs storage driver. Here’s some additional info on my system which has worked flawlessly through all of the upgrades over the years from ownCloud 8.x through NextCloud 13.0.1:

~$ docker info

Containers: 2
Running: 1
Paused: 0
Stopped: 1
Images: 2
Server Version: 17.03.1-ce
Storage Driver: btrfs
Build Version: Btrfs v4.4.1
Library Version: 101
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 4ab9917febca54791c5f071a9d1f404867857fcc
runc version: 54296cf40ad8143b62dbcaa1d90e520a2136ddfe
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 4.4.0
Operating System: Slackware 14.2
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.953 GiB
Name: hammer
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
WARNING: No swap limit support
Experimental: false
Insecure Registries:
Live Restore Enabled: false

I’ve backed out several times and even completely deleted not just the collabora/code container, but also the image, and I can pretty much go through all of the steps with my eyes closed, following exactly what the instructions say. I used LE for certs, all are valid.

More details are located here:

I have the same issue on Debian Stretch, did you ever manage to solve this?

Do’h, I hadn’t set the Collabora Online server URL in the settings — it would be nice to have a check for stupid user behaviour like this :wink: