Internal server error on update NC 9 -> 10 and 10->11

Happy to see this posting as I’d been postponing updating from 9.0.53 as the updater didn’t work and alternative descriptions on the net seemed complicated. I followed the instructions in the updater to update to 10.0.2 however the process gets stuck in the next to last step “Move new files in place” with the following text:

"Parsing response failed. 500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

"

The only non-standard thing in my configuration is that following what seemed to be sensible advice I store my files in a separate data directory not embedded in the nextcloud directory. The updater doesn’t seem to have a problem with that as there is a current updater.log file in that separate data directory.

Will very much appreciate any help as the system is now out of service!

Thanks

Well, not obvious what happened there. I was able to update to 10.0.2 by following the manual instructions in https://hagen.cocoate.com/2016/08/26/update-nextcloud-version-9-53-10-0/
The updater script had left the new version unzipped on the server in the following path: /data/updater-ocg9o36v7gj1/downloads/nextcloud so I moved those files to the real nextcloud directory. Next I removed the “‘maintenance’ => true,” line from the saved config.php and uploaded it to /nextcloud/config. Calling the nextcloud page in the browser started then the update process which was successful except for some file consistency messages (had to delete the logs directory and rescan for them to disappear).
In conclusion: The new updater doesn’t seem to work under all circumstances, but the manual process isn’t that difficult after all.

And BTW it doesn’t work for me for the update from 10.0.2 to 11.0.0. Same failure as posted above. So beware!
I’d really like to know what is wrong as I was really hoping to be able to update without so much fuss!

Can you please take a look in your server logfiles? The error log should contain more information. Zip-module installed in PHP?

Thanks for your interest. By server logfiles you mean what is stored under /data/nextcloud.log or something about the sharehoster server (all-inkl)? I don’t see in the nextcloud.log much of interest (but I might have lost the log immediately after the error).
What I see in the log after the manual upgrade in a OC\NeedsUpdateException:
0. /nextcloud/lib/private/legacy/app.php(123): OC_App::loadApp(‘federation’)

  1. /nextcloud/lib/base.php(960): OC_App::loadApps(Array)
  2. /nextcloud/index.php(48): OC::handleRequest()
  3. {main}

just before starting upgrade from 9.0.53.0 to 9.1.2.2

The Zip-module should be installed as the files for the new version are unzipped on the /data/updater-ocg9o36v7gj1/downloads/nextcloud directory.

Hi,
which mySQL(i) version are you using?
Have the same message/problem with mySQL 5.0, after i switch to mySQL 5.7.x everything works again :slight_smile:

According to the hoster information page the system is using MySQL 5.5.52-nmm1-log - (Ubuntu). This is probably not something I can change this being a shared webhosting service (all-inkl.com).

Good way is to start with a clean log, reproduce the error and check was has been logged. Not sure if all-inkl also provides more logfiles of the webserver. Might be on some logs-folder in your webspace or perhaps the webinterface of your provider. Some errors can also show up in your nextcloud.log but some may not.

You can also ask ALL-INKL to move you to a newer server if you don’t have anything running which needs a lower php and sql version. I just moved to php 7 and mysql 5.7 just to get things running faster. To ask them just login in the Member Area and use the Contact Field.

I’m not sure if it is helping to solve your problem, but i used the updater to update from NC 9 to NC 10 some time ago and everything was fine. (also all-inkl)

Well, now with the release of 11.0.1 I tried once more to update using the updater. I’d move in the meantime to a new server at all-inkl with mysql 5.6.33-nmm1-log - (Ubuntu) and switched to PHP 7.0 as CGI/FPM but everything to no avail: Same error! So it might be that the mysql version is at fault. Fortunately the same manual workaround as described above worked. Thanks for all the replies.

Well with PHP 7.0 through CGI/FPM you didn’t upgrade your server at all-inkl. Just write to the support and you’ll be moved in the next days. It’s really convenient to upgrade NC with the new updater :slight_smile:

I finally got around asking the all-inkl support to upgrade my server to provide php 7.1 as Apache-Module. Surprisingly, I haven’t found much information on how to set up ownership and permissions of the nextcloud files to make the move from cgi/fpm to mod_php. Right now all files are owned by the FTP user and permissions are set to 755/644. Just changing the owner everywhere to www-data doesn’t seem to be right as it is a good practice to have all PHP-files be read-only to prevent infections (except for the update case where they need to be written).
Does anybody have a good pointer to how to move from cgi/fpm to mod_php?

PS: Ok I found the following two links but only in the 9.0 documentation. They disappeared in the corresponding spots in 10.0 and up. WHY?

https://docs.nextcloud.com/server/9.0/admin_manual/installation/installation_wizard.html#setting-strong-directory-permissions

For Upgrade:
https://docs.nextcloud.com/server/9.0/admin_manual/maintenance/update.html#set-updating-permissions-label