Internal Server Error (NC27 Stable)

Hallo,

ich habe ein Debian12 mit Apache2.4 und einer NC27.
Folgendes ist passiert bzw. habe ich versaut.

Als erstes habe ich ein Update auf NC27 vollzogen, alle Fehler und Warnungen beseitigt, so das NC27 in einen sauberen Zustand ist.
Ein Tag danach habe ich ein Upgrade von Debian11 auf Debian12 durchgeführt.
Anschließend kann ich Nextcloud nicht mehr aufrufen und folgende Meldung kommt:
= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.
= = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =
Keinerlei Error im Serverlog vorhanden.
Mein Document Root ist auf /var/www/nextcloud gesetzt.
Ändere ich Document Root auf /var/www funktioniert das darin befindliche Dokuwiki astrein, so dass ich davon ausgehen kann, dass der apache2 fehlerfrei läuft. Klicke ich dann auf den Nextcloud-Ordner kommt der Error wieder.

Hat hier jemand eine Idee dazu?

Grüße
Mike

The details will be in your nextcloud.log.

If I had to guess: Since you were running NC27 prior to the Debian 12 upgrade, you were likely using a PPA source for PHP. Please verify all of the appropriate PHP extensions are installed since Debian 12 would have either replaced your prior PPA based PHP installation or tried to install alongside it.

https://docs.nextcloud.com/server/stable/admin_manual/installation/source_installation.html#prerequisites-for-manual-installation

Es liegt am Memory Cache und wird durch redis verursacht. Sobald ich die Einträge aus der config.php heraus nehme läuft auch NC27 wieder.
Warum das so ist weis ich noch nicht. Ich schaue weiter, da ich nun wieder folgende Warnungen habe:

  • Die Datenbank wird zum Sperren von Transaktionsdateien verwendet. Um die Leistung zu verbessern, richte bitte, sofern verfügbar, Memcache ein.

  • Es wurde kein PHP Memory Cache konfiguriert. Konfiguriere zur Erhöhung der Leistungsfähigkeit, soweit verfügbar, einen Memory Cache.

Schau mer mal weiter.

Folgende Pakete, um alle getätigten Einstellungen zu löschen, mit apt purge gelöscht
redis-server php-redis php-apcu

Danach neu installiert und in der NC config.php folgendes, nach $CONFIG = array (
eingetragen:

‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘filelocking.enabled’ => ‘true’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘127.0.0.1’,
‘port’ => 6379,
‘timeout’ => 0.0,
),

Nun läuft NC27 wieder richtig ohne Fehlermeldungen und Warnungen.