"Internal Server Error" NC 15.0.6.1 / NCP 1.12.0 Upgrade to NC 16?

ncp
nc15
update_problems
#1

[/details]

Nextcloud version: 15.0.6.1
NCP version: 1.12.0
Operating system and version:
Raspbian GNU/Linux 9
Linux cloud 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019 armv7l GNU/Linux
Apache or nginx version: Apache/2.4.25 (Raspbian) OpenSSL/1.0.2r
PHP version:

The issue you are facing:

When opening NC I get “Internal Server Error”
NCP-Panel is dispayed and shows “erverything o.k.”

Is this the first time you’ve seen this error? : Y

Yesterday system worked as normal. NCP autoupdate function is on.

The output of your Nextcloud log in Admin > Logging:

??? where to find if NC isn't running

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

root@cloud:/var/log# cat /var/www/nextcloud/config/config.php
<?php
$CONFIG = array (
  'passwordsalt' => '',
  'secret' => ',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    11 => '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>302 Found</title>
</head><body>
<h1>Found</h1>
<p>The document has moved <a href="https://icanhazip.com/">here</a>.</p>
</body></html>',
    1 => '192.168.10.53',
    5 => 'nextcloudpi.local',
    7 => 'nextcloudpi',
    8 => 'nextcloudpi.lan',
    9 => 'cloud',
...
  ),
  'datadirectory' => '/media/nc-data/ncdata',
  'dbtype' => 'mysql',
  'version' => '15.0.6.1',
  'overwrite.cli.url' => 'https:///',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'ncadmin',
  'dbpassword' => '',
  'installed' => true,
  'instanceid' => 'ocgzqno3xb8d',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => '',
  ),
  'tempdirectory' => '/media/nc-data/ncdata/tmp',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'cloud',
  'mail_domain' => '',
  'overwriteprotocol' => 'https',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '',
  'mail_smtpport' => '587',
  'mail_smtpname' => ',
  'mail_smtppassword' => ',
  'maintenance' => false,
  'logfile' => '/media/nc-data/ncdata/nextcloud.log',
  'loglevel' => 2,
  'jpeg_quality' => '60',
);

#2

Nc is not a program or service.
Apache2, Mariadb and Redis servers are, NC depends on them.
You can check there status with nc-info in either ncp-web or ncp-config.

NC 16 is not yet fully tested by NCP devs.
So how and why did you manually update to NC 16?

Content of ncp.log or output of ncp-report may be of use ( thru pastbin or similar), if you need further assistance.

#3

No manual update at all. I just assumed, that ncp started an unattended upgrade.

ncp-report see ncp-report-klausb

#4

Temporarily solved

I deleted the additional 20-opcache.ini in /etc/php/7.2/cli/conf.d and restartet php-fpm

But where does ist come from?

1 Like
#5

auto unattended upgrades, updated some php packages and recreates those extra opcache.ini files, it is a bug that keeps coming back somehow. There is no harm in it and is safe to remove. However, It does not produce any “internal server Error”
Just rebooting your system or running systemctl daemon-reload or reloading php-fpm might have fixed that.

unattended upgrades, only takes of care security updates for the OS. It does not upgrade NC or NCP. Update references in docs.

1 Like
#6

looks like I had the very same problem. KlausB’s workaround did the job for me. running ncp v1.12.0 with unattended security updates enabled. Oliver’s suggestion executing systemctl daemon-reload did not work on my raspbian.

edit:
further more users running on docker might not be facing this issue as they hopefully receive security updates through new docker images. Assuming the 20-opcache.ini is not baked into the image and always generated on the first start of the daemon, they might newer run in these bad situations. Can anyone confirm?

Dom