Internal Server Error after 'reinstall'

I am experiencing the internal server error after trying to install nextcloud. This is following a reinstall after receiving the same error after trying to install certbot.

Nextcloud version *22.1.1_2
Operating system and version *Freenas 11.3-U5
Apache or nginx version *nginx 1.20.1
PHP version *7.4.24

The issue you are facing: Internal server error

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Access nextcloud through browser

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

I also need help gathering the logs and various outputs

Hello, can you please show us the config.php file? Did you configure redis?

How do i get the output of the config file?
when i copy and paste it restructures the contents

I did not configure redis

Nextcloud log

GNU
nano
8
{“regId”:"7V43FAS2BvhmAfBtrcql
{“regId”
: "7V43FAS2BvhmAfBtrcql
{“regId”
: “IVKhBs4Dat jDRKv2rBnV”
{“regId”
“tsZRZ1c96R6uavOWClaj”
{“regId”
: “HdV3vc6vAtFovPWJXxV7”
{“regId”: “byLtgubHo3VbUSOEfMNh”
{“regId”
“eRFYXsvaz9l4ysRet2dG”
{“regId”
: “MmPHeQJKJHHYoaZioPOt”
{“regId”: “KVS1szghllLZx00tGiro”
{“regId”
"j6pB78 j4QCt55ezfFP8g
{“regId”
: “HGanMMKjWER9iCYRxTaI”
{“regId” : “FWizL5r9Rpvs9NgL3crw”
{“reqId”
"64MvfFHBLOpJhMtgm6rg
{“regId”
: "7Mdd0T5FsAI1JkngFuMw
{“regId”: "WPAs1j5ARVuB5Aw2xVQa
{“regId”:“5B5bIm7xqyCn6S35mRos”
nextcioua. Loc
"level

  1. 3,
    "time
    ": “2022-01-17T18:22:00+00:00”
    "level
    ", 3,
    "time
    “2022-01-17T18:22:00+00:00”
    "level
    ".2,
    "time
    " .
    “2022-01-17T18:52:29+00:00”
    "level
    • 3,
    "time
    2022-01-1718:52:30+00:00
    "level
    ". 3,
    "time
    "2022-01-17T18:52:30+00:00
    "level
    ". 3,
    "time
    Il

    "2022-01-17T18:52:34+00:00
    "level
    • 3,
    "time
    "2022-01-17T18:52:34+00:00
    “level”:2,
    "time
    "2022-01-17T18:52:48+00:00
    "level
    ": 3,
    "time
    Il

    "2022-01-17T18:52:48+00:00
    "level
    • 3,
    "time
    "2022-01-17T18:52:48+00:00
    "level
    ". 3,
    "time
    "2022-01-17T18:52:50+00:00
    "level
    ": 3,
    "time
    11 •
    “2022-01-17T18:52:50+00:00”
    "level
    • 3,
    "time
    "2022-01-17T19:02:06+00:00
    "level
    ", 3,
    "time
    "2022-01-19T21:24:52+00:00
    "level
    ": 3,
    "time
    1:
    "2022-01-19T21:44:50+00:00
    , "level
    1: 3,
    “time”:
    “2022-01-19T22:00:03+00:00”

nginx error log

2022/01/17 18:44:06 [error] 15756#101818:
*25 upstream timed out (60: Operation>
2022/01/17 18:45:07 [error] 15756#101818:
*25 upstream timed out (60:
Operation>
2022/01/17 18:51:14 [error] 15759#100552:
*32 upstream timed out (60:
Operation>

config output

SCONFIG

array
‘apps paths’
array
(
0
=>
array
path
=>
‘url’
=>
'writable

"/usr/local/www/nextcloud/apps’
"/apps
=>
true,
)
1
=>
array
"path
=>
‘url’
=>
‘writable
‘/usr/local/www/nextcloud/apps-pkg’
"/apps-pkg
=S
true,
)
).
logfile’
=>
passwordsalt
/var/log/nextcloud/nextcloud.log
=>
'qt/iF/i0700rbz1SI/s7WC6N0r5I85
secret
=>xxxxxxxxxx
'trusted domains
(
=>
array
0
=>
1
2
3
=>
=>

'localhost
xxxxxxxxx.com,
).
datadirectory
=>
dbtype
=>
'mysql
"version
=>
'22.1.1.2
'overwrite.cli.url
=>
’ dbname
=>
'nextcloud
"dbhost
=>
'localhost
dbport
=>
'dbtableprefix
=>
mysql.utf8mb4
'oC
=>
true,
"/usr/local/www/nextcloud/data
"http://localhost
" dbuser
=>
‘dbpassword’
'installed
’ instanceid
'oc ncadmin
=>
=>
true
=>
‘xxxxxxxxx’

Indeed not easy to read the logs and config
Did you change any of these settings?

  'trusted_domains' => 
  array (
    0 => '192.168.X.X',
  ),

Exactly!
I just added the nextcloud instance’s IP and the domain i will be using for external use

I added the nextcloud instance’s ip address and the domain name i will use to access it externally

Any thoughts?

Hi @Takudzwa_Munyoro, sorry for the delay, Can you send the whole error please, we don’t have information about the real issue with this …

to avoid the restructure of contents use this before and after your copy-paste ``
like this : `test`