Internal server error after reboot

First of all, I want to clarify that the nextcloud server is local.

Hi, I installed nextcloud on ubuntu server, precisely on the external disk (in /mnt/usb)

clearly I added the disk to fstab so that nextcloud starts automatically on every reboot.

as soon as the installation is finished, nextcloud works without problems, the interface page opens correctly.
but after restart I get “Internal Server Error”
i tried to read the logs in /mnt/usb/var/www/html/nextcloud/data/nextcloud.log
but it is empty.
What can I do? i also tried using docker compose

What version of NC? What image?

Since you’re not actively using docker compose, can you please post the docker run commands you are using? We need more information.

And either the output of occ config:list system or the contents of your config.php (redacted!).

Image ubuntu server 22.04.2

nextcloud version: 27.0.1 (latest)

if I do nano config.php it’s all empty, instead if I do nano occ I get this:
GNU nano 6.2 occ #!/usr/bin/env php

<?php /** * Copyright (c) 2013 Thomas Müller * This file is licensed under the Affero General Public License version 3 or * After. * See COPYING-README file. */ //$argv = $_SERVER['argv']; require_once __DIR__ . '/console.php'; I tried the installation again, as soon as I finished installing the gui ( it opens correctly, then I restart and I get Internal Server error.