Internal Server Error after PHP upgrade 7.4

Hi guys,

i recently planed to upgrade my php from 7.2 to 7.4. After upgrading i got the “Internal Server Error” page and my apache log file is showing the following: “client denied by server configuration: /var/www/nextcloud/config”. The nextcloud log is empty.

I already have used the search function but are not able to find a soultion for me. Now i have again activated the php7.2 in the meanwhile to run the NC instance.

What could be the problem?
I am using the newest ubuntu system (18) and NC.

Thank you and best regards!

PHP 7.4 is not compatible with NC18. Not compatible means it is not tested, so there can be problems, and you shouldn’t rely on it. Does have to mean that your error is really related to that.

NC 19 will be compatible and once the first test versions are out, you are welcome to run tests on this new version (please use a dedicated test setup): https://github.com/nextcloud/server/wiki/Maintenance-and-Release-Schedule#nextcloud-19

Now i tried PHP 7.3 but unfortunately same error with PHP7.3.

[Sun Mar 08 09:49:57.957312 2020] [mpm_prefork:notice] [pid 1303] AH00169: caught SIGTERM, shutting down
[Sun Mar 08 09:50:38.217700 2020] [mpm_prefork:notice] [pid 1282] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1 configured – resuming normal operations
[Sun Mar 08 09:50:38.258557 2020] [core:notice] [pid 1282] AH00094: Command line: ‘/usr/sbin/apache2’
[Sun Mar 08 09:50:44.150201 2020] [access_compat:error] [pid 1404] [client 80.110.27.103:52409] AH01797: client denied by server configuration: /var/www/nextcloud/config
cat: /sys/class/net/docker0/speed: Invalid argument
cat: /sys/class/net/docker0/duplex: Invalid argument
cat: /sys/class/net/wlp58s0/speed: Invalid argument
cat: /sys/class/net/wlp58s0/duplex: Invalid argument
cat: /etc/ntp.conf: No such file or directory
cat: /etc/ntp.conf: No such file or directory
cat: /etc/ntp.conf: No such file or directory

Well, something with php<->apache changed? Wrong user or something? You use docker, in that case I don’t don’t anything docker specific, but others can probably help you.

No, i don’t use docker. I only use docker for Collabora.

Is there any solution? I have the same issue by switching from 7.2 to 7.3

Please open a own thread with all details (nextcloud version, php version, problem, logs, screenshots, …)