Internal server Error after memcaching

Nextcloud version (18.0.10):
Operating system and version (Debian 10):
Apache or nginx version (Apache 2.4.):
PHP version (7.2):

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

The issue you are facing:

I set up a Nextcloud server. Everything worked fine, until I tried to implement memcaching. I did it like explained here in the single server organization section. Since them the web interface always gives an internal server error

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. setup a Nextcloud in apache on Debian 10
  2. Install Memcaching as described above

The output of your Nextcloud log in Admin > Logging:

[this is the  output of nextcloud/data/nextcloud.log because, well, the web interface isn't working because of the internal server errror...]
{"reqId":"oVAZrn9njV15eBPY1RfR","level":3,"time":"2020-02-05T19:00:14+00:00","remoteAddr":"::1","user":"--","app":"no app in context","method":"GET","url":"/index.php/csrftoken","message":{"Exception":"RedisExc$
{"reqId":"17hwMfmwQdmJbf8A9ECM","level":3,"time":"2020-02-05T19:00:25+00:00","remoteAddr":"","user":"--","app":"no app in context","method":"GET","url":"/index.php/csrftoken","message":{"Exception"$
{"reqId":"xufHGw8RBUVJd6roJ6Ai","level":3,"time":"2020-02-05T19:10:45+00:00","remoteAddr":"","user":"--","app":"no app in context","method":"GET","url":"/index.php/csrftoken","message":{"Exception"$
{"reqId":"sq7jZG3l6R8DupTNyBVY","level":3,"time":"2020-02-05T19:12:14+00:00","remoteAddr":"cut out","user":"--","app":"no app in context","method":"GET","url":"/index.php/csrftoken","message":{"Exception":"RedisExc$
{"reqId":"rGIVhBeXmgSp6g35KSVV","level":3,"time":"2020-02-05T19:12:26+00:00","remoteAddr":"cut out","user":"--","app":"no app in context","method":"GET","url":"/index.php/csrftoken","message":{"Exception"$

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

  'memcache.local' => '\OC\Memcache\APCu',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => [
     'host'      => '/var/run/redis/redis.sock',
     'port'      => 0,

The output of your Apache/nginx/system log in /var/log/____:

cut out - - [05/Feb/2020:20:19:24 +0100] "GET / HTTP/1.1" 301 629 "-" "Mozilla/5.0 (Android 9; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0"
cut out - - [05/Feb/2020:20:19:25 +0100] "GET / HTTP/1.1" 200 4293 "-" "Mozilla/5.0 (Android 9; Mobile; rv:68.0) Gecko/68.0 Firefox/68.0"
cut out - - [05/Feb/2020:20:19:27 +0100] "GET /favicon.ico HTTP/1.1" 404 3776 "-" "Mozilla/5.0 (Android 9; Mobile; rv:68.4.1) Gecko/68.4.1 Firefox/68.4.1"

I am facing a similar issue after enabling redis. is there any solution to this please?