Internal Server Error after latest NextCloud Update

Hi, I´m getting the amous internal server error after update of nextcloud.

Running latest NextCloud 22 on an ubuntu 18 with MariaDB and PHP 7.4 (also tried 7.2 and 8.0 already)

Any idea where I should start to search the error?

The Log file shows the following:

{“reqId”:“BTanXV3mZ9rZkaESc1tv”,“level”:3,“time”:“2021-09-24T14:21:30+00:00”,“remoteAddr”:“”,“user”:"–",“app”:“core”,“method”:“GET”,“url”:"/",“message”:{“Exception”:“OC\HintException”,“Message”:“Memcache \OC\Memcache\Redis not available for local cache”,“Code”:0,“Trace”:[{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:677,“function”:"__construct",“class”:“OC\Memcache\Factory”,“type”:"->"},{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:155,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",“args”:["*** sensitive parameters replaced "]},{“file”:"/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\AppFramework\Utility\{closure}”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:"->",“args”:[" sensitive parameters replaced ***"]},{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:122,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->"},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",“line”:156,“function”:“query”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:"->"},{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:1677,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->"},{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:1017,“function”:“getMemCacheFactory”

as you didn’t reference your MariaDB version I just try an educated guess - you upgraded the DB as well, which is not supported now

Hi wwe, thanks for your reply. I just checked the MariaDB version with
mysqld --version
mysqld Ver 5.7.35-0ubuntu0.18.04.2 for Linux on x86_64 ((Ubuntu))

so it seems much older then 10.6 I guess. The problem started after I did a
sodo apt-get upgrade but how do I identify the item that was not upgraded correctly?

I’m not an expert in Ubuntu - but I don’t see any reference to “real” mysql anymore. everybody seems to use MariaDB now - maybe you should migrate as well. ubuntu 18.04. is not really fresh as well…

Myself I hate this kind of answers - there might be a reason to keep an older version - then you should know your system and know how to fix the issues, otherwise you must follow the mainstream… I wish you good luck, hopefully you fix the problem.

Thanks wwe,
just did an Ubuntu 20.4 upgrade, however it´s of course still bringing the same error.

Anyone else has an idea? I´d like to avoid to reinstall the complete NextCloud and copy 2TiB of data back to it manually. And all the brang and shared links with other people etc. would be gone as well…

please double check check you have backup of your data. If unsure run this now it still could be enough. generally speaking you need a backup of your (config), data directory and database - apps are optional to return to exactly same state. as long you don’t loose your DB all the meta-data is safe and available for restore.

once you have the backup you may try to reinstall every component one by one and carefully reviewing/restoring the data after each step. maybe start with replacing MySql with MariaDB - this one most likely kept untouched by OS upgrade. It should be possible to restore MySql backup into fresh MariaDB. if this doesn’t help try reinstall Nextcloud and configure same DB credentials and data folder as you have now… maybe you find useful hints in official docs