Internal Server Error after docker-compose update to 20.0.7

Hi,

Im running Nextcloud with docker-compose and NGINX reverse proxy manager as my reverse proxy (different container). After updating Nextcloud from 20.0.4 tot 20.0.7 by doing:

docker-compose down
docker-compose pull
docker-compose up -d

The container is updated but now I cant access my instance of Nextcloud. Can anybody help me?

I get the following message:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

My Compose file:

version: '3'

services:
  db:
    image: mariadb
    command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
    restart: always
    volumes:
      - ./nextcloud/db:/var/lib/mysql
    environment:
      - MYSQL_ROOT_PASSWORD=XXXXXXXXXXXXXXXXXX
      - MYSQL_PASSWORD=XXXXXXXXXXXXXXXXXX
      - MYSQL_DATABASE=nextcloud
      - MYSQL_USER=nextcloud

  redis:
    image: redis:alpine
    restart: always

  app:
    image: nextcloud:latest
    restart: always
    ports:
      - 8888:80
    volumes:
      - ./nextcloud:/var/www/html
      - /media/vdb/data:/var/www/html/data
      - ./nextcloud/config:/var/www/html/config
      - ./nextcloud/apps:/var/www/html/apps
      - ./nextcloud/php.ini:/usr/local/etc/php/conf.d/zzz-custom.ini
    environment:
      - MYSQL_HOST=db
      - MYSQL_PASSWORD=XXXXXXXXXXXXXXXXXX
      - MYSQL_DATABASE=nextcloud
      - MYSQL_USER=nextcloud
      - NEXTCLOUD_TRUSTED_DOMAINS=192.168.5.242
      - REDIS_HOST=redis
      - NEXTCLOUD_ADMIN_USER=ncadmin
      - NEXTCLOUD_ADMIN_PASSWORD=XXXXXXXXXXXXXXXXXX
    depends_on:
      - db
      - redis

  cron:
    image: nextcloud:apache
    restart: always
    volumes:
      - ./nextcloud:/var/www/html
    entrypoint: /cron.sh
    depends_on:
      - db
      - redis

My Config.php

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'redis',
    'password' => '',
    'port' => 6379,
  ),
  'passwordsalt' => 'XXXXXXXXXXXX',
  'secret' => 'XXXXXXXXXXXX',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '192.168.5.242',
    2 => 'portal.XXXXXXXXXXXX.com',
  ),
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'mysql',
  'version' => '20.0.4.0',
  'overwrite.cli.url' => 'https://portal.XXXXXXXXXXXX.com',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'XXXXXXXXXXXX',
  'installed' => true,
  'instanceid' => 'XXXXXXXXXXXX',
  'defaultapp' => 'files',
  'knowledgebaseenabled' => false,
  'auth.bruteforce.protection.enabled' => true,
  'skeletondirectory' => '',
  'overwriteprotocol' => 'https',
  'overwritehost' => 'portal.XXXXXXXXXXXX.com',
  'updatechecker' => true,
  'enable_previews' => true,
  'preview_max_x' => 2048,
  'preview_max_y' => 2048,
  'preview_max_filesize_image' => 30,
  'default_locale' => 'nl_NL',
  'default_language' => 'nl',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'support',
  'mail_domain' => 'XXXXXXXXXXXX.com',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'XXXXXXXXXXXX',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'XXXXXXXXXXXX',
  'mail_smtppassword' => 'XXXXXXXXXXXX',
  'maintenance' => false,
  'check_data_directory_permissions' => false,
);

I tried changing my user permissions but no luck. Any tips? When I grep the nextcloud.log it is impossible to read (no structure).

1 Like

Still need help. Tried sudo chown -R www-data:www-data all and sudo chown -R www-data:www-data all inside the container and the host.

No success.

Nobody? I really need it to work again and all the solutions on the forum are not working.

I see that you have setup redis, got plenty of server errors trying to configure it. Try to put redis and app on the same docker-compose network. Also set a password to your redis otherwise you might encounter issue with login, especially if you have 2FA activated.

I can confirm that there is the same problem without Redis.

1 Like

Thanks for your reply. I have had Redis running from the beginning and had no problems. They are in the same docker-network. Adding the PW didn’t help unfortunately.

Any other tips?

I ran into the same error message - not sure yet wether it was after upgrading to 20.0.7 or a ‘apt upgrade’ - but commenting out those two lines disabled redis and it worked. But you might want to check the error message in nextcould.log first.

This is not a solution yet though - disabling redis slows nextcloud down. But at least it got my installation working again.

1 Like

Sorry for the late reply. Was sick for a couple weeks.

Disabling Redis didn’t help unfortunately. The logs keep reading the same entries:

Configuring Redis as session handler,
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 192.168.32.4. Set the ‘ServerName’ directive globally to suppress this message,
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 192.168.32.4. Set the ‘ServerName’ directive globally to suppress this message,
[Fri Mar 26 21:49:09.123765 2021] [mpm_prefork:notice] [pid 1] AH00163: Apache/2.4.38 (Debian) PHP/7.4.16 configured – resuming normal operations,
[Fri Mar 26 21:49:09.124207 2021] [core:notice] [pid 1] AH00094: Command line: ‘apache2 -D FOREGROUND’,

It seems to be docker thats Fing my configuration as I have set the QDname…

Anyone else have tips?

I’m struggling with the same issue.

I have the same problem as well.

I found a solution that works for me !
I had to update libsecomp2.
download a version of libsecomp2 >= 2.4.4 (see Debian -- Details of package libseccomp2 in buster-backports)
wget http://ftp.de.debian.org/debian/pool/main/libs/libseccomp/libseccomp2_2.4.4-1~bpo10+1_armhf.deb
install the new library (make sure you have libc6>2.17 installed)
sudo dpkg -i libseccomp2_2.4.4-1~bpo10+1_armhf.deb