Internal Error 500 after upgrading to 13.0.52

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

This is driving me bananas. The web updater would not run because of permissions issues. I ran this:
sudo chown -R www-data:www-data /var/www/nextcloud

and then the updater ran perfectly. But when it finished and tried to redirect me back to the web page, I got the Internal Server error.

Nextcloud version (eg, 12.0.2): 13.0.5.2
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.18 (Ubuntu)
PHP version (eg, 7.1): 7.0.30-0ubuntu0.16.04.1

The issue you are facing: After upgrading from 13.0.2.1 to 13.0.5.2 I can no longer access the Nextcloud web interface. Syncing from the computer and phone works fine.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. I have no way to replicate. Cannot revert to 13.0.2.1

The output of your Nextcloud log in Admin > Logging:

{"reqId":"tzPkMCsqFPUegp1mnA0i","level":3,"time":"2018-07-25T14:35:17-04:00","remoteAddr":"192.168.100.8","user":"ncadmin","app":"index","method":"GET","url":"\/apps\/files\/","message":"Exception: {\"Exception\":\"RuntimeException\",\"Message\":\"image not found: image:app.svg webroot: serverroot:\\\/var\\\/www\\\/nextcloud\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/nextcloud\\\/apps\\\/contacts\\\/appinfo\\\/app.php(35): OC\\\\URLGenerator->imagePath('contacts', 'app.svg')\\n#1 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/NavigationManager.php(114): OC_App::OCA\\\\Contacts\\\\AppInfo\\\\{closure}(*** sensitive parameters replaced ***)\\n#2 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/app.php(651): OC\\\\NavigationManager->getAll()\\n#3 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/TemplateLayout.php(83): OC_App::getNavigation()\\n#4 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/legacy\\\/template.php(207): OC\\\\TemplateLayout->__construct('user', 'files')\\n#5 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/public\\\/AppFramework\\\/Http\\\/TemplateResponse.php(157): OC_Template->fetchPage()\\n#6 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Dispatcher.php(114): OCP\\\\AppFramework\\\\Http\\\\TemplateResponse->render()\\n#7 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/App.php(115): OC\\\\AppFramework\\\\Http\\\\Dispatcher->dispatch(Object(OCA\\\\Files\\\\Controller\\\\ViewController), 'index')\\n#8 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/AppFramework\\\/Routing\\\/RouteActionHandler.php(47): OC\\\\AppFramework\\\\App::main('ViewController', 'index', Object(OC\\\\AppFramework\\\\DependencyInjection\\\\DIContainer), Array)\\n#9 [internal function]: OC\\\\AppFramework\\\\Routing\\\\RouteActionHandler->__invoke(Array)\\n#10 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/Route\\\/Router.php(297): call_user_func(Object(OC\\\\AppFramework\\\\Routing\\\\RouteActionHandler), Array)\\n#11 \\\/var\\\/www\\\/nextcloud\\\/lib\\\/base.php(999): OC\\\\Route\\\\Router->match('\\\/apps\\\/files\\\/')\\n#12 \\\/var\\\/www\\\/nextcloud\\\/index.php(42): OC::handleRequest()\\n#13 {main}\",\"File\":\"\\\/var\\\/www\\\/nextcloud\\\/lib\\\/private\\\/URLGenerator.php\",\"Line\":218}","userAgent":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/66.0.3359.181 Safari\/537.36","version":"13.0.5.2"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
    'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '192.168.100.253',
    2 => 'cloud.XXX.com',
    3 => 'cloud.XXX.com',
  ),
  'datadirectory' => '/var/ncdata',
  'overwrite.cli.url' => 'https://cloud.XXX.com/',
  'dbtype' => 'mysql',
  'version' => '13.0.5.2',
  'dbname' => '',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'instanceid' => '',
  'maintenance' => false,
  'mail_smtpmode' => 'sendmail',
  'log_rotate_size' => '10485760',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => true,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0,
    'dbindex' => 0,
    'password' => '',
  ),
  'htaccess.RewriteBase' => '/',
  'loglevel' => '2',
  'log_type' => 'file',
  'logfile' => '/var/ncdata/nextcloud.log',
  'logtimezone' => '',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'cloud',
  'mail_domain' => 'XXX.com',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'XXX.com',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'email_address',
  'mail_smtppassword' => 'password',
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
  'updater.secret' => '',
  'theme' => '',
);

The output of your Apache/nginx/system log in /var/log/____:

[Wed Jul 25 06:25:05.126517 2018] [mpm_prefork:notice] [pid 1780] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Wed Jul 25 06:25:05.126535 2018] [core:notice] [pid 1780] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jul 25 14:34:57.571641 2018] [mpm_prefork:notice] [pid 1780] AH00169: caught SIGTERM, shutting down
[Wed Jul 25 14:35:10.213570 2018] [mpm_prefork:notice] [pid 1814] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured -- resuming normal operations
[Wed Jul 25 14:35:10.220311 2018] [core:notice] [pid 1814] AH00094: Command line: '/usr/sbin/apache2'

That bad, eh? :slight_smile:

Might be a https problem. Do you access your cloud via http or https? What is the setting of your clients, as you say they are working?

Happens with both. All clients work fine.