Integrity Check: Ignore File/Directory Array

Nextcloud version (eg, 10.0.2): 11.0.2
Operating system and version (eg, Ubuntu 16.04): Ubuntu 16.10
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.18
PHP version (eg, 5.6): 7.0
Is this the first time you’ve seen this error?: No

Can you reliably replicate it? (If so, please outline steps): When running the automatic updater

The issue you are facing:
I am on a server which creates a set of files and directories in the root when a new vhost is created. My NextCloud instance is installed in this same root. When ever you want to do an upgrade via the browser, the integrity check complains about these added files/directories. Is there something that can be added in the config to ignore an array of files and/or directories so that the upgrade may continue?

for me certbot/autoconfig (.well-known) and changes to .htaccess (additional security headers, #121) are causing this rather annoying warning. integrity.check.disabled isn’t quite a valid option as long as you do not implement an external integrity monitor. An array to define exceptions for integrity check or even an option to mark the current file hash as valid/supply custom hashes would help in situations as described here.

What about the ‘integrity.excluded.files’ array in config.php the Ownclouders have?
(just migrated to Nextcloud a few days ago and I´m missing this option quite well)

On my virtual hosting I manage websites via ISPConfig, and it creates stats and logs directories, which I need to move on every upgrade, and it’s annoying. An option to ignore those dirs would be nice!

Thanks for all your work


1 Like

I have the same issue. Cpanel creates that .well-known folder …
Is there a solution?