Integration of external cloud services does not work

Hello everybody!

I am trying to integrate an external cloud service into Nextcloud. Unfortunately, I have not yet succeeded in doing so.
Specifically, I would like to integrate “Magenta Cloud” via WebDav. I have installed the plugin “External Storage”. And I have a WebDav address of Magenta Cloud ( But it’s not working.
What am I doing wrong? Many thanks in advance!

S o l v e d !
Now I try to integrate the “Fritzbox”. Unfortunately I do not know a WebDav address. It doesn’t seem to work right away either. Has anyone done this yet?

i just setup a magentacloud for free… just to be able to help you.
since you provided really NO info about what you did where…
and i can tell you… the integration went smoothly at first try.

i would open a new thread for it.

solving goes like this:

make yourself an account for magentacloud. enable extra password (within the service) for being able using webDAV with it.
go to your nc-admin-settings - external storage - choose “webDAV” from dropdownmenu “add storage” - choose “username and password” under authentification, enter in configuration - leave directory blank - check https - enter credentials (use password you just just setup beforehand at magentacloud-service) - fill in directory name if you want to - hit check. and the green light should appear.

Thank you very much for your help! Shortly after I wrote my contribution, I saw what the problem is:
With Magentacloud you have to create your own password for WebDav access. I tried my normal password. That was my fault.

The integration works now. However, there is a restriction:
I can’t copy data from a Nextcloud folder to a Magentacloud folder. But it seems to work the other way around. Is that the same for you?

An addition:
When trying to upload data to Magentacloud, the following error message appears:

“Client error response [url] [status code] 404 [reason phrase] Not Found”

umm i only tried the way copying from NC to MC. and it worked perfectly (i even could share it from there via android-app and watch it somewhere else).

but i only tried a small file. i’m gonna try a bigger one now

I’m very jealous now :wink:
I don’t know why copying from NC to MC doesn’t work. From MC to NC there are no problems. Maybe any write permissions. But the settings at MC are very limited. I didn’t find anything there.

in the meanwhile i tried copying a 1gb file from NC to MC and it worked flawlessly (it just took a while).

i didnt change anything for it, made no fuirther adjustments. so it worked from the beginning on for me.
have you encountered more problems with your NC-instance, lately?

could you share your NC.log? maybe there are errors showing up

No, I have no other problems with NC at the moment. It works well.

I assume you mean the nextcloud.log from the data directory:

there seems to be a problem with your given email… pls check (dunno if thats the source of your problem w/ MC)

some apps complain in the log.
but all in all i cant see where’s the problem. but i am sure others are able to find out more (maybe it’s just a wrong permission or such). so pls don’t delete the log as if it seems to be very helpful for others.

i’m outta here since i can’t help you any more. sorry.



I would like to ask again whether there is a solution to the problem described.
I can’t copy data from a Nextcloud folder to a Magentacloud folder. But it seems to work the other way around. There is an error message every time (see above).

Many thanks in advance!