Instant Upload no longer works

Unfortunately no, I’ll see that I can take a look at the beta the upcoming days. Sorry for all the trouble,still need @tobiasKaminsky though since I just did the UI part :frowning:

No problem, currently I have a preliminary solution.

Just confirming that my Nexus 6P (android 7.1.1) is not auto uploading anything. I’ve done restarts on server and phone and messed with the limited options I’ve found and nothing has auto uploaded yet. :confused:

EDIT: It does seem to upload at least some new taken pictures now (all of the first 8 photos/videos I tried). I found a post elsewhere suggesting this was a current limitation. The way the app shows you your back catalog when turning on auto upload really suggests that it will start uploading the images there already. What I wanted this first trial run with Nextcloud to do was primarily suck in all my photos from my phone over wifi when I get home each day and not expose my cloud to the internet yet. I will have to test what happens when I take photos away from home and come back. Will they be “new” still?


another confirmation on a Mate9 running Android 7.0 with App version 1.4 (from Play Store). Camera pictures are not uploaded at all on my phone, even Though I have “Storage location” set as well as InstantUpload configured and I enabled all relevant folders in the “Auto Upload” menu (great job about that btw, I have been secretly hoping to see something like this for a while now :slight_smile:).

If I take pictures using the Lightroom-App weirdly are uploaded nearly instantly. Same goes for Screenshots. It seems that mainly pictures shot by the Huawei Camera App are not uploaded.

Since the Mate9 has a pretty decent Camera and I would like to use that quite often, I am really hoping that this can be fixed. If I can help anyhow, please let me know. I don’t know if there is any usable debug info you can get from an unrooted phone, but I am glad to provide you with any information I can.

Sorry, my english is very bad. But I try to explain it anyway.
If my FolderSync syncs something, then Nextcloud also works. But it uploads any thumbnail files.


for me the New auto upload feature also not working.
Selecting a folder in the auto upload works. but if i take a New picture it wount upload.
The nextcloud app also does not recognize new files so the upload queue is empty.

So do i have to turn on some Services?


They will yes, depending on if you have confgured wifi-only uploads and also haven’t connected to any other wifi until then (else that would trigger the upload).[quote=“Boballen55, post:23, topic:5980”]
It does seem to upload at least some new taken pictures now (all of the first 8 photos/videos I tried). I found a post elsewhere suggesting this was a current limitation.

Can you find the link for this one, because there shouldn’t be a limit. The next release will also have a waiting-time, so that we don’t try to grab the photo instantly but wait for 10 seconds and then try to do the work since Android’s stock camera is post-processing the photos which leads to issues with out Auto upload…[quote=“gibbon, post:24, topic:5980”]
It seems that mainly pictures shot by the Huawei Camera App are not uploaded.

Do you now if Huawei is doing some kind of post-processing or anything which might block our folder watchdog to gain the information that there are new images?

So which files will then get uploaded? The “normal” photos too? And what are the “other” files or rather the file extensions since we now also integrated a patch for the next release that will skip .tmp files.

You don’t. What is the app version, Android version and device model-name/vendor? Doesn’t it work at all (no photos, no screenshots, etc.) or just not for the standard camera?

@Andy No the normal photos are not uploaded. Only the .thumbnail files are uploaded. But only if I start the APP FolderSync.

@tobiasKaminsky do you think this will be fixed by the 10 seconds delay ?

Hey Andy,

I used the beta app from 24.12.2016. I have Android 6.0.1 on my galaxy s6.
and yes auto upload won’t work for any folders. like Screenshots, whatsapp, camera etc…
New pictures wont get to the upload queue. So they are not recognized by the nextcloud app

That’s too bad. I’m always jumping on WiFi away from home and my Nextcloub box isn’t on the internet so most of the time it won’t auto upload for me.

Sorry for not being clear. I was not referring to 8 being some limitation but rather the fact that the images must be “new”. This is the quote where I was getting that from

A “synchronize all non-uploaded” is planed for future version which will still need some time since we need to iron out bug of the new auto upload and also add further other features to it first before we get to the point to implement a sync / upload existing files.

With a few days of trying to use auto upload I am getting inconsistent uploads with Open Camera. Haven’t played with other cameras. I’ve been trying to have it only upload when on WiFi and charging for the last couple days. I’ve just gotten a few random photos that were uploaded. Can’t see a pattern.

What happends to the others? Aren’t they detected or did they make it to the uploads view but have a failed state?

They are not ending up in the uploads view. Best I can tell the app just ignores them. Is there a log file I should find?

A log file can only be found in the settings at the bottom in case you run the beta client. The stable releases do not have a log at the moment, but that is something which is on the todo list.

Hi there,

Please note that I am new and have set up my Nextcloud V11.01 on my Zorin (Ubuntu) laptop which purely using it as cloud storage and upload and accessing files. It is all working and set up properly now and I am using Huawei P9 plus Android 6. Initially I had random uploading issues using different listening port (on both mobile and home wireless network) then I changed it back to standard ports. I was quite happy everything was working but then the problem started again. Nextcloud on my phone will randomly upload some pictures and some of them I had to manually upload them. Also, even if I managed to connect (say uploaded pictures taken right now… and pictures I took couple minutes or a day ago were not uploaded, it WON’T automatically upload them like Google Drive would). And I kept on getting notification on my Desktop (randomly whether I am accessing nextcloud or not) but when I click on the notfiication, it doesnt show any error. I have sort of selected some of the error on the log and it said it might be a bug? Please find the link to access some of the error I have on the log and it is only accessing internally using the wireless network. I hope it helps!

I experience the exact same things. The notification on the desktop says something about action being required, right? I haven’t found any message other than the notification. Auto upload on my 6p is spotty and I can’t figure out a pattern.

1 Like

Hey Boballen55,

I know and it is very frustrating as I cannot understand why I kept on getting notification on my Zorin desktop. Therefore I hope the log file I have attached would help to shed some light.

And I just remembered something on my Huawei P9 plus and perhaps you should also check it out. For Huawei, they use a lot of Battery / power management so it stops the process of applications if you don’t choose it to stay awake… it is useful when it comes to apps which you don’t use often, like File manager or note or drawing applications. So I just realised that Nextcloud application has been switched off (power management so it will not remain active after certain time). So I am going to monitor mine now after switching it on so it will remain in the background process / memory. So maybe try that and let me know as well? (It is actually very silly of me NOT TO think of it!) XD

Hi guys,

@mario is currently improving the auto upload feature (new fixes available in the beta app) which will be shipped with our next release.

I did turn off battery optimization for a day but it still missed an image. There was an update to the Android app since then so I will turn that off again and let you know how it goes in a couple days.