Installing Collabora error

When I try to install the Collabora Online - Built-in CODE Server, I get the following message: An error occured during the request. Unable to proceed. Collabora is installed.

When I use the command line php -d memory_limit=512M occ app:install richdocumentscode , I get Could not open input file: occ

Where do I start with this?

DrP

Hi,
Try it with
/path_to/occ (e.g. /var/www/nextcloud/occ)

php -d memory_limit=512M /path_to/occ app:install richdocumentscode

Thank you Helge.

When I entered the command with the corrected path, I got the following message:
Console has to be executed with the user that owns the file config/config.php
Current user id: 0
Owner id of config.php: 33
Try adding 'sudo -u #33

When I entered:
sudo -u #33 php -d memory_limit=512M /home/cloud/public_html/occ app:install richdocumentscode

I got this message
sudo: option requires an argument – 'u’

I’m confused. What am I missing?

BTW, I modified php.ini to set memory_limit=512M and restarted apache, but had no effect.

Again…Thanks.

Patrick

Well…after reviewing the sudo man page, I used sudo --user=#33 instead of -u #33.

The response was:
richdocumentscode 6.4.303 installed
richdocumentscode enabled

That did it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.