Installing app, Password confirmation is required?

I am sure this is a Newbie question, when I am installing an app, I get a message that password confirmation is required, but I don’t even see a place to enter a password. Am I doing something wrong? If it matters, I am the admin on the installation.

It looks like I needed to use a different browser. Thanks anyway.

Can you tell us on which browser it didn’t work and which you are finally using? Firefox and Chrome should be supported, there are perhaps limitation with IE.

With me Opera 42.0.2393.351 /Linux does not work
Chromium Version 55.0.2883.87 does not show password confirmation required

I also get this, not sure how its solved. I even go into the admin user I am using and CHANGE/RESET my own password and it still gives me that error.

Yes, it sometimes happens that users don’t tell how they solved this. If the window is not popping up, there is perhaps something blocking it (add/script blocker), the browser console is a good starting point. I’ll close this here, please open a new topic if you find this problem.