Installation of nextcloud on nginx (on raspi) without a bought domain

This is part of the solution, now the error is

An unhandled exception has been thrown:
 Error: Call to undefined function OC\App\simplexml_load_file() in /usr/share/nginx/nextcloud /lib/private/App/InfoParser.php:65
Stack trace:

Does a reboot help?

no same error as before

Are you running the occ command as www-data user?
If yes, could you execute: sudo -u www-data php occ maintenance:repair

Which Nextcloud version are you using?
Is there an update in settings available?
Could you post the full stack trace?

Just installed php-xml as axplained here and not it only complains that is is indead executed as root :wink:
An issue might be that I actually installed php7.2 but most interfaces want 7.3 nowadays (I’ve read a tutorial and made it as said there, but is seams the tutorial was outdated :/)

So you have a mixed environment of php 7.2 and 7.3? Not good.
The occ command should always be executed by www-data user.

php 7.2 is still supported, so If you only installed php7.3-mysql, remove it apt-get remove php7.3-mysql and install the 7.2 version.

Don’t you think it would be better to swich over to 7.3 ?

(uninstalling what the tutorial made me installing and install it ad the 7.3 version)

Sure, just wanted to spare you the effort. Although it’s not much :slight_smile:

Yea it’s already installing :wink:

So finally I just have two questions left: Since I always access my nextcloud from the local network (or via vpn, which results in a similar thing) do I need https?

And have you any experience in installing nextcloud on nginx and adding pihole afterwards?

No, if your local network is secure and there are no unknown devices, you do not need https.
But it adds security anyway. I’m even using it in my fully isolated network :smile:
If you have some spare time, set it up.

Sorry, can’t help you with that one. Never used it.
EDIT: But it sounds interesting will have a look…

Ok so I don’t know how to thank you. But especially after knowing how much knowledge I was missing to get this working I now know that I could have never done this alone.

Yes pihole is cool but I want neither get in the docker thing nor do I want to have to use a seccond rpi but I will see.

I really don’t want to bother you another time but now after switching to php7.3 (hopefully all went right) I get a “bag gateway” when trying to access the nextcloud interface. The access log indicates that now the GET request comes from the ipv6 address instead of like earlier from the ipv4 address :man_shrugging: no idea what might have caused this

Edit: But the access log of nextcloud shows get requests of a ipv4 address…
But anyhow the error is a bad gateway

Haha no problem :smile: You would have done it anyway, it would have been just more expensive in terms of time.
The bad gateway is probably related to php7.3 instead of php7.2.
Search your nginx conf files for a reference to php7.2 and exchange it with 7.3.

Yea just saw it :smile:

1 Like

So satisfying to see it working now xD
So thanks again, should I in case I find something with pihole tell you how I got it working? (but don’t expect anything since in terms of networking and handling a server I’m a newbie in contrast to linux in general ;))

Is it ok if I don’t select a message as solution or should I select one in which the initial question is solved best?

Glad to hear it’s working! Just spread the word and if you can, help others to bring their personal data under their control.
I’m not sure about the solution marker. Probably just select something to have the thread marked as solved :wink:

Have fun with your Nextcloud!

1 Like

Thanks :ok_hand: :+1: