Install on Windows Desktop Docker in a DMZ

Hello, I am absolutely noob in Linux and Docker - but I have a to do:
I have a Windows Server 2019 behind a Sophos SG in a DMZ running. I installed Desktop Docker and NextCloud AIO Container.

I set up a DNAT on Sophos of all services to route to the internal ip address of the dmz server.

From internet, I can reach for config (A-Host setting done).

But when in config i want to set up the domain then i get an error:

“Domain does not point to this server or the reverse proxy is not configured correctly. See the mastercontainer logs for more details. (‘sudo docker logs -f nextcloud-aio-mastercontainer’)”

So, now, i didn´t want to use a reverse proxy at this time, when nextcloud is running, i can use the reverse proxy function of my sophos firewall.

Terminal log shows following:

[Thu Jan 26 12:07:28.547305 2023] [php:notice] [pid 281] [client] The response of the connection attempt to “ttp://” was: , referer: ttps://
[Thu Jan 26 12:07:28.547345 2023] [php:notice] [pid 281] [client] Expected was: 51cd1424fb901a13758f701f2a218a314123456789d2, referer: ttps://
[Thu Jan 26 12:07:28.547360 2023] [php:notice] [pid 281] [client] The error message was: Empty reply from server, referer: ttps://

Can someone help me? I will get crazy with this…

Thank you very much.

Hi, did you follow all-in-one/ at main · nextcloud/all-in-one · GitHub step-for-step?

Or is sophos not a reverse proxy?

In that case you might skip the domain validation with GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

Hello, thank you for answers.

I CAN setup sophos as a reverse proxy, but didn´t do that, my first target was, to bring um the nextcloud running.

I tried to set up reverse proxy, but didn´t sure where i should set up comands? In Terminalsession of the docker container? Or I need to download one of the proxies in the manual (e.g. Apache, ngix and so on) and set up comands there?

Sorry for stupid questions, linux and docker are not my world…

If you xan leave out sophos and port-forward port 443 directly to your windows server which hosts Docker, that would be the easiest option.

Stupid question, where I should run the “-e SKIP_DOMAIN_VALIDATION=true” comand?

I try it in the terminal console of the docker container, but then i get the message: -e: not found …

Edit: OK, i deleted the container, and put the e-Skip comand in the install line.

But for future it would be great to know, where put in this comands…

You need to stop and remove the mastercontainer (no data will be lost) and use the same command that you used but with the variable added to the docker run command…

1 Like