Install 3rd party app

Hi everybody,

I tried to install this https://apps.owncloud.com/content/show.php/Files+Share+Link+Renamer?content=174742 which is supposed to be compatible with Nextcloud 11.

After downloading, copying to …/apps/ and chown -R apache:apache I can see the app listed under ‘Not enabled’ section, but when I choose to activate it I get an error message ‘Could not download app sharerenamer’.
I even added ‘appcodechecker’ => false, in config.php, but no results.

How can I solve this?

Regards, Laurentiu

1 Like

Extract the archive into apps/ and then chown it.

And contact the maintainer to publish it on the Nextcloud app store

I did extract it into apps/, verified it, it’s ok.
Changed ownership to apache:apache like all other apps.

Doesn’t work… Cannot contact the maintainer, this was yesterday’s topic :))
If it’s not published, it means it cannot work?? What’s the point of having 3rd party apps then?

What’s the point of having 3rd party apps then?

There is no point :slight_smile: This should actually work fine (if you did everything correctly). It also works on my local machine btw although i didnt try your app archive. My guess is that you’ve downloaded the wrong archive or the app is borked

Where did you download it from? I mean if you tried Share Renamer.

I downloaded it again from github, repeated the process, same result…

wtf… I renamed the folder app to ‘sharerenamer’ and works fine…

1 Like

3rdparty app is 3rdparty broken :slight_smile:

Dear guys,
I updated from NC11 to NC12 today after which I found out that sharerenamer was deactivated (it was working fine up to then).
Then I git cloned the github into nextcloud/apps/sharerenamer and edited info.xml to reflect max NC version 12.0.
I then ran php occ to enable the app.
I get “Fatal: error” when trying to rename links in NC now :confounded:
The button for renaming shows up though.

Any advice?

Thanks!

@der.einstein so you removed the compat check for an incompatible app and enabling it fails, what did you expect? Also please create a new topic, your question is unrelated to the actual topic