Initializing NextCloudPi for the first time stuck


I have a problem to setup NextCloudPi mit docker.
I use a Rpi 4 with 4GB RAM.
I have used a new 16Gb SDCard with Rasbian OS lite.

I used the commands to install docker and NexcloudPI:

curl -fsSL | sh

sudo usermod -aG docker pi
newgrp docker

sudo apt-get install -y libffi-dev libssl-dev

sudo apt-get install -y python3 python3-pip

sudo pip3 -v install docker-compose

My docker-compose.yml:

image: ownyourbits/nextcloudpi:latest
container_name: nextcloudpi
command: (my Windows PC)

  • 4443:4443
  • 443:443
  • 80:80
  • ./volumes/nextcloudpi/ncdata:/data
  • /etc/localtime:/etc/localtime:ro
    restart: unless-stopped

I start the system with:

sudo docker-compose up -d

This is the log from Nexcloudpi

Initializing empty volume…
Making /usr/local/etc/ncp-config.d persistent …
Making /etc/services-enabled.d persistent …
Making /etc/letsencrypt persistent …
Making /etc/shadow persistent …
Making /etc/cron.d persistent …
Making /etc/cron.daily persistent …
Making /etc/cron.hourly persistent …
Making /etc/cron.weekly persistent …
Making /usr/local/bin persistent …
Making /etc/apache2 persistent …
Starting PHP-fpm
Starting Apache
Starting mariaDB
2021-01-25 14:44:08 0 [Note] mysqld (mysqld 10.3.22-MariaDB-0+deb10u1) starting as process 137 …
Starting Redis
Starting Cron
Starting Postfix
System config value trusted_domains => 1 set to string
System config value trusted_domains => 6 set to string
Provisioning Redis password
Updating NextCloud config with Redis password
Provisioning MariaDB password
Updating NextCloud config with MariaDB password
Running nc-limits
Using 3010403328B for PHP
Using 6 PHP threads
Using 953136128 memory for the database
Stopping MariaDB database server: mysqld.
Starting MariaDB database server: mysqld.
Stopping redis-server: redis-server.
Starting redis-server: redis-server.
Init done

I get to Webside with the passwords and use the Button “Activate”
I get to the Webside :4443 and this is the System Info:

System Info

‣ You should run Lets Encrypt for trusted encrypted access

NextCloudPi version v1.34.6
NextCloudPi image NextCloudPi_docker_01-19-21
distribution Debian GNU/Linux 10 \n \l
automount no
USB devices none
datadir /data/nextcloud/data
data in SD yes
data filesystem ext2/ext3
data disk usage 5.0G/15G
rootfs usage 5.0G/15G
swapfile /var/swap
dbdir /data/database
Nextcloud check ok
Nextcloud version
HTTPD service up
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok
port check 80 open
port check 443 open
interface eth0
certificates none
NAT loopback no
uptime 55min

Now I want to go to the website :443 and there is only

Initializing NextCloudPi for the first time
Please wait…

and then nothing more happens

Do anybody have an idea?

Thanks for your help.

Greetings Tobias

Maybe check this bug report , not sure if affected your setup…
A fix was pushed recently, try run ncp-update and then nc-init, and watch log for init done.

Hello OliverV,

thanks for you help.
I run ncp-update and it updatet to version v1.34.7

But when I want to run: nc-init
It says: bash: nc-init: command not found

Where can I fin the nc-init?

Greetings Tobias


Hello OliverV

thanks for your help.

But still I dont find the nc-init…

Is there a other way to run nc-init?

Greetings Tobias

Hi there, created an account just to comment, as I was also trying to deploy nextcloudpi and having the exact same problems as you. Logs looked OK, but was stuck at initializing page. Running on an RPI 4 8gb and tried reinstalling, even my OS and starting from scratch, with both 32 bit and 64 bit beta OS.

In my internet search I found that it may not be our fault! See the recent issues filed in github:

so I guess I will just wait for a proper image to be released.

Yes, sorry, it is not available in docker version.

Just start a new container if want same result as nc-init.

I have exactly the same problem here. Pihole is running on Raspberry Pi and Nextcloud in docker image. I have changed the port 80 from pihole to 90 but no success.

I have created my own network for nextcloud on docker, but this is also not working.

Any hint would be very helpfull.

1 Like

How can I pull an older NextCloud docker image?

docker pull ownyourbits/nextcloudpi-armhf

always pulls the latest image.

docker pull ownyourbits/nextcloudpi-armhf:version ???

I am having a mare with NextcloudPi, 4gb Raspberry Pi 4. Have not been able to get the new image working - freezes on the activate screen. I have tried many times - different cards/devices. I even put a post - but it seems to be a similar problem reported here…

Cant use NextcloudPi on RPI.