Infinite loading circle

#1

Hi,

i installed collabora with docker right now and tried to create a new document. But i always get only a infinite loading circle and no error message in the protocol/log at the admin account.

How can i check if collabora is running correctly? … or is there another log which i can read out?
The docker is running (docker ps) … and otherwise i would not be able to see the loading circle.
If i open in browser office.mydomain.com, i see the apache2 default page, is this correct?

Thank you and best regards!

Collabora with S3 backend fails with fseek() errors
#2

Try to open a existing document, if this works you don’t have a problem with Collabora but with the Nextcloud Collabora app.
To see the Apache default page with office.mydomain.com is ok, try office.mydomain.com/loleaflet/dist/admin/admin.html
If you see the Collabora admin page your Collabora setup is (probably) ok.

#3

Thank you for your answer … if i type in the domain, a popup for login is coming. Which username and password should i type in?

I reinstalled the docker image, now i get this message when i create a new document: “unauthorized WOPI-Host”. If i try to open a existing one, i see the infinity loading cicle.

#4

In a non-Docker installation you can set User/password in /etc/loolwsd/loolwsd.xml . How you do it in Docker I don’t know.
In a non-Docker installation you have to have something like:
# WOPI discovery URL
ProxyPass /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse /hosting/discovery https://127.0.0.1:9980/hosting/discovery
in your Apache setup. Again I don’t know how you do it in Docker.

#5

In my apache config is such a code:

WOPI discovery URL

ProxyPass /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse /hosting/discovery https://127.0.0.1:9980/hosting/discovery

#6

Did you enabled:
a2enmod proxy
a2enmod proxy_wstunnel
a2enmod proxy_http
a2enmod ssl
and restart Apache?

#7

Yes - checked it right now.

#8

From https://nextcloud.com/collaboraonline/
Unauthorized WOPI host. Please try again later and report to your administrator if the issue persists.
you might have started the docker container with the wrong URL. Be sure to triplecheck that you start it with the URL of your Nextcloud server, not the server where Collabora Online runs on.
Did you check tuis also?

1 Like
#9

Thank you, this was my first fault. I used the office/collabora domain for starting the docker image.

But it is still not working:

  • Now i get this message by creating a new document: Well, this is embarrassing, we cannot connect to your document. Please try again.
  • … and still a infinity loading circle at a existing document. :neutral_face:
#10

Maybe you could post your docker command for starting and your apache configuration for collabora.
With the url, user , password and other security parts anonymized of course.

#11

Docker Code:

docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=domain\\.to\\.nextcloud' -e 'dictionaries=de en' --restart always --cap-add MKNOD collabora/code

Apache:

<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerName office.dedyn.io
RewriteEngine on

# Some rewrite rules in this file were disabled on your HTTPS site,
# because they have the potential to create redirection loops.

# RewriteCond %{SERVER_NAME} =office.dedyn.io
# RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

Include /etc/letsencrypt/options-ssl-apache.conf

# Encoded slashes need to be allowed
AllowEncodedSlashes NoDecode

# Container uses a unique non-signed certificate
SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

# keep the host
ProxyPreserveHost On

# static html, js, images, etc. served from loolwsd
# loleaflet is the client part of LibreOffice Online
ProxyPass /loleaflet https://127.0.0.1:9980/loleaflet retry=0
ProxyPassReverse /loleaflet https://127.0.0.1:9980/loleaflet

# WOPI discovery URL
ProxyPass           /hosting/discovery https://127.0.0.1:9980/hosting/discovery retry=0
ProxyPassReverse    /hosting/discovery https://127.0.0.1:9980/hosting/discovery

# Main websocket
ProxyPassMatch           "/lool/(.*)/ws$" wss://127.0.0.1:9980/lool/$1/ws nocanon

# Admin Console websocket
ProxyPass    /lool/adminws wss://127.0.0.1:9980/lool/adminws

# Download as, Fullscreen presentation and Image upload operations
ProxyPass /lool https://127.0.0.1:9980/lool
ProxyPassReverse   /lool https://127.0.0.1:9980/lool

# Endpoint with information about availability of various features
ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

SSLCertificateFile           /etc/letsencrypt/live/office.dedyn.io/fullchain.pem
SSLCertificateKeyFile    /etc/letsencrypt/live/office.dedyn.io/privkey.pem
</VirtualHost>
</IfModule>
#12

As far as I can decide that all looks good.
So I only have two suggestion left:
Check again https://nextcloud.com/collaboraonline/, the trouble-shooting part at the end of the page.
In your settings for Nextcloud check again the settings for collabora online. Did you configure the right server (collabora and not nextcloud)

#13

Hi,
I had exaclty the same problem…seems linked to the docker image.

To solve it, I enter the docker image and make some change like this

sudo docker exec -it 617f6b3afd7e bash (where 617… is the container ID)
root@617f6b3afd7e:/# echo 172.17.0.1 your.nextcloud.instance.ext >>/etc/hosts
root@617f6b3afd7e:/# exit

I hope it helps.

(but you need to do it each time you restart docker…)

1 Like
#14

Thank you, this worked also for me. But would there be a solution not to retype this with every restart?

#15

…I have no idea
Is it a bug or a feature? if it’s a bug, let’s hope it will be solved in a future version of the docker image.
I have neither the time nor the expertise to investigate…sorry.

#16

You don’t have to type those commands on every restart. It basically copies your changes into the docker container. If however you need to make changes to the hosts file or any file within the container, you’ll have to do that again however.

Do me a favor. Restart the container a few times and see if the /etc/hosts file is overwritten on restart. I don’t think it should be however I don’t have a container to actually test with.

#17

I am having the same issue. I tried editing the hosts file in the container but it still a problem. Hopefully the docker image will be fixed soon.

#18

What message are you getting in your nextcloud.log?

#19

I was not seeing any errors in the log I double checked some settings turns out I also had some DNS caching problems that were also in the way. Once those were resolved editing the hots file worked perfectly.

#20

@bgsteiner, so you found a way not to retype echo 172.17.0.1 your.nextcloud.instance.ext >>/etc/hosts after every restart?

After a system restart, docker? is removing the host entry 172.17.0.1 your.nextcloud.instance.ext