Index TypeError: Return value must be of the type integer, float returned

Hi, getting a lot of log spam at the moment by the index app. Nextcloud is working perfectly though, just want to get this fixed before updating to version 15.

Running Nextcloudpi on an odroid xu4. My ncp-report: https://pastebin.com/T2wSELA5

This is what the logging says: (app: index)

TypeError: Return value of OC\MemoryInfo::memoryLimitToBytes() must be of the type integer, float returned

0. /var/www/nextcloud/lib/private/MemoryInfo.php - line 55:

OC\MemoryInfo->memoryLimitToBytes(2147483648)

1. /var/www/nextcloud/lib/private/MemoryInfo.php - line 39:

OC\MemoryInfo->getMemoryLimit()

2. /var/www/nextcloud/settings/Controller/CheckSetupController.php - line 623:

OC\MemoryInfo->isMemoryLimitSufficient()

3. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 166:

OC\Settings\Controller\CheckSetupController->check()

4. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 99:

OC\AppFramework\Http\Dispatcher->executeController(OC\Settings\ ... {}, "check")

5. /var/www/nextcloud/lib/private/AppFramework/App.php - line 118:

OC\AppFramework\Http\Dispatcher->dispatch(OC\Settings\ ... {}, "check")

6. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:

OC\AppFramework\App::main("OC\\Setting ... r", "check", OC\AppFramew ... {}, { _route: "s ... "})

7. OC\AppFramework\Routing\RouteActionHandler->__invoke({ _route: "s ... "})

8. /var/www/nextcloud/lib/private/Route/Router.php - line 297:

call_user_func(OC\AppFramew ... {}, { _route: "s ... "})

9. /var/www/nextcloud/lib/base.php - line 987:

OC\Route\Router->match("/settings/ajax/checksetup")

10. /var/www/nextcloud/index.php - line 42:

OC::handleRequest()

my MemoryInfo.php:

https://pastebin.com/pzNdCPaU!

Getting this at the same time

Same Issue for me!

This error could be due to a too high memory_limit in php settings (>2GB)!
I could fix this error by reducing “memory_limit” setting in php.ini below 2048MB.

unfortunately no, it’s currently at 512M

Same error here. No one knows what to do?

Not really a solution, but:
the value of 2147483648 is too high (by 1) for a 32Bit integer.
So PHP selects float as data type.
It should help to set the ini value to lower than 2048M.

Edit: do you get the same error row in your log?