Increase space / storage nextcloud vm since nextcloud 19


until nextcloud 19 i used a set of commands to increse the free storage space of nextcloud vm
i mean after insalling the vm for first use

i create a new disk in vmare workstation pro

then use the commands below

First, run df -Th to verify the “ncdata” size

second After scanning or rebooting, run fdisk -l to view all the partitions

third , verify the current “ncdata” size using zpool list

fourth, use the below command to add the new partition to the ZFS Pool. In our example, we are adding the partition “sdc” to the ZFS Pool ncdata

zpool add ncdata sdc

fifth Run zpool list again afterwards to verify the increased size

All these steps works great in nextcloud 14 vm, 15, 16, 17, 18 and increase the space

However in nexcloud 19 vm

after writing the command
zpool add ncdata sdc and rebooting the machine

nextcloud server fail from running

writing zpool list in the console
give an error

in a normal opearaion in nextcloud 14 until 18 you can see the picture below

however in nextcloud 19 vm the “health” i got is faluty

"and another strange thing i got an error of "No pools available

since i can’t increase the space in nexcloud 19 i use nextcloud 18 no more upgrades for me

Does anyone has any knowledge what the correct set of commnands to increase storage space after clean install of nextcloud 19 and a fresh adding hard-disk in the vmare worksation

i mean after clean install of the vm and adding hard drive here

what commands should i use in nextcloud 19 vm
the regular commands of zpool add ncdata sdc make the vm crash and no pools available

Sorry i do not use zpool. But was is the error?
Nextcloud uses a data-dir configured in config/config.php.
Is it on the correct partition:
df /path/to/nextcloud-data-dir
Is the user (e.g. www-data) correct for the data-dir /path/to/nextcloud-data-dir?

Please post more details and logs. Thanks.
Please cut and post outputs and use code-blocks or screenshots.

some more information

in the url
Your data directory is invalid Ensure there is a file called “.ocdata” in the root of the data directory. Your data directory is not writable Permissions can usually be fixed by giving the webserver write access to the root directory. See

in the console


while boot the machine i got the errors below

is there another way to increase the 40 gb of the official vm

the guide here make problems in nextcloud 19

it worked perfect until nextcloud 18
but since nextcloud 19
after following the guide

i get errors

Your data directory is invalid Ensure there is a file called “.ocdata” in the root of the data directory. Your data directory is not writable Permissions can usually be fixed by giving the webserver write access to the root directory. See

if there is another way to increase space or add more space to the nextcloud vm that come with 40gb it is ok for me to make a clean / fresh install completely

buy since i am a begginer i will need help on how to do it
until nextcloud 19 i followed the guide

and it was perfect

please find the attached pdf

Can you not upgrade your existing VM to version 19? Why the clean installation?

If you’re at the point of modifying the VM to this extent, you might consider just installing Nextcloud yourself and using a filesystem you’re more familiar with.

upgrade between magor release
like 18 to 19
is not possible in the vm

upgrade is possible beteen 16 to 16.1
antoher example 18 to 18.03 and so on

obviously i do something wrong maybe i miss one or two commands
you can see in the pdf the health status before adding space
size 39.5 gb health online
after the command sudo zpool add ncdata sdc
the actual size of the partition is 1 TB
but the health is faulted and the system is corrupted
there must bes somthing i do wrong
please take a look at page number three

trying to upgrade via the web admin page

You can update to major NC versions with the following command in the VM:
sudo bash /var/scripts/

Hmm. Maybe I’m spoiled by Docker. All I have to do is pull new images and I’m updated perfectly every time.

As I said:

upgrade completed
a lot of time but time is not issue for me at all

sudo bash /var/scripts/
solve the problem
now the health is online
no errors


maybe a good thing to do in vmare is to export the vm in order to save it
i can do it with vmare professional


thanks everyone


I am in the same situation, I installed the vm to replace and old existing nextcloud installation. I want to extend the existing 40 GB disk to 1 TB disk. I followed your steps and everything went fine until I rebooted the machine, the same problem as you got. How did you solved that? Now I got this:

root@nextcloud:~# zpool list
no pools available


I would like to ask about this too. Is there a way to extend the storage without the need to do a fresh install from an OVA with bigger storage pre-configured? Would appreciate the possibility.


I ran into this same issue. ZFS was corrupted after I issued “zpool add ncdata xvdc” where xvdc was my new 1TB disk. Fortunately I took a snapshot first. So I revered back and got nextcloud working on the original 40GB again. Then, this 2nd time I added /dev/ to the disk name in the command:

zpool add ncdata /dev/xvdc

To my surprise, all is good:

1 Like