Incorrectly requesting status.php

So I have a server with the following stats:

  • CentOS 7
  • Apache Webserver
  • PHP 7

The Desktop NextCloud Client is requesting URL: and is reporting back that the file was not found. But that’s a bad URL to request since the file is available (I have checked) at:

How can I change the URL request in the Desktop Client or what can I do?

Here is my .conf file (scrubbed of any identifiable information):

I have the same problem. I have nextcloud configured at and I do not understand why the client forces me to use

I cannot understand why no one is complaining because this is a problem that touches a lot of people

The Desktop App for Windows 10?
It works perfectly for me. Did you upgrade your servers meanwhile while you had the client already configured? Or did you migrate from Owncloud to Nextcloud?

Have you tried to reset the app in the settings menu?

After resetting you should be asked to enter the server domain.

Fresh installation. Installed nextcloud. Downloaded desktop app for windows10 from nextcloud site. Installed desktop app for ubuntu from ubuntu repository. Both ask me for domain " and both append “owncloud” to that domain.

My installation is under a reverse proxy that exposes only
Are you sure that your installation does not expose also
In that case is obvious that it will work.


Can you please provide the output of your status.php when you enter your.domain.tld/status.php and also your.domain.tld/nextcloud/status.php in your web browser?

It is really strange, because I only entered my domain in the NC app (https://sub.domain.tld). In another app I entered the my server address as https://sub.domain.tld/remote.php/webdav/ maybe you can try that as well. Just adjust it to your domain with your.domain.tld/nextcloud/remote.php/webdav/

My server definitely doesn’t react to /owncloud. I never installed owncloud and didn’t migrate. I started with Nextcloud 11. Don’t know if earlier installations provide the string owncloud somewhere and therefor tell the Apps that they need to append /owncloud.
Did you run an Owncloud server some time ago, migrated to Nextcloud and now with a new installation used some older config files or something like that?

I never installed nextcloud or owncloud before. I started from Nextcloud 12.
Here is my.domain.tld/nextcloud/status.php:{“installed”:true,“maintenance”:false,“needsDbUpgrade”:false,“version”:“”,“versionstring”:“12.0.4”,“edition”:"",“productname”:“Nextcloud”}
my.domain.tld/status.php does not exist because my reverse proxy blocks it
It seems to me a client problem because the client appends owncloud and wants that I write “https://my.domain.tld” in the input field.
Suppose I mapped my installation to my.domain.tld/foobar/ , in this case will the client work?

You need to contact the maintainer of the Client software then. I don’t know who this is.
Seems like a bug in the client software to me.

There are no further settings in the app, right?

Edit: just saw that @rullzer maintains the client software. Maybe he can help.

There is a fallback that seems to still use /owncloud if the status.php can’t be found at the given url.

I’ll make an issue an look into it.

1 Like

Sounds like

I have done other tests and I have discovered this:

So a missing end “/” causes the problem. I suppose the code should add an end slash automatically and, as you said, the fallback should use /nextcloud

1 Like