Incorrect big files sizes after upgrade to NC19

Nextcloud version: 19.0.0
Operating system and version: Raspbian/Debian 10.4
Apache or nginx version: 2.4.38
PHP version: 7.3

The issue you are facing:
In the Web UI and also in the oc_filecache table the size of file is incorrect.

  • Expected as seen on filesystem: 4001157588
  • In details view: -293809708 B
  • In the list: Pending
  • In the table: -293809708
    retrieved using: select * from oc_filecache where path like ‘%GOPR0475%’;

Is this the first time you’ve seen this error?: Y

Steps to replicate it:

  1. Having the NC 18.xx
  2. Upload the file of size 4GB
  3. Check it’s sizes in all mentioned places
  4. manually upgrade Nextcloud only to the 19
  5. check the filesize on web UI - list declares Pending, details view negative value

The output of your Nextcloud log in Admin > Logging:

{"reqId":"411FaGvhREpBzP1nwHKP","level":1,"time":"July 07, 2020 10:17:18","remoteAddr":"","user":"koren","app":"no app in context","method":"GET","url":"/nc/apps/files/","message":"Deprecated event type for OCA\\Files::loadAdditionalScripts: Symfony\\Component\\EventDispatcher\\GenericEvent","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0","version":""}
the message is repeating

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'updatechecker' => false,
  'instanceid' => 'removed',
  'passwordsalt' => 'removed,
  'secret' => 'removed,
  'trusted_domains' =>
  array (
  'datadirectory' => '/nc/data',
  'overwrite.cli.url' => 'removed',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'removed',
  'dbpassword' => 'removed',
  'logtimezone' => 'removed',
  'installed' => true,
  'theme' => '',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud.log',
  'logfilemode' => 0640,
  'loglevel' => 0,
  'logdateformat' => 'F d, Y H:i:s',
  'log_rotate_size' => true,
  'maintenance' => false,
  'filelocking.enabled' => true,
  'enable_preview' => true,
  'preview_max_x' => 8192,
  'preview_max_y' => 8192,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0.0,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'knowledgebaseenabled' => true,
  'htaccess.RewriteBase' => '/nc',
  'mysql.utf8mb4' => true,
  'has_rebuilt_cache' => true,
  '' => 'stable',

The output of your Apache/nginx/system log in /var/log/____: not available, is not generated
in configured location

Additional info:
After returning back to previous version:

  1. restore backup
  2. truncating oc_filecache and oc_filecache_extended
  3. performing occ files:scan --all

the file sizes are correct.

The same here! After Update to NC 19.0.2 all files bigger than 2GB are shown “pending”! And the client-synchronization are getting wrong!!
Bevor everything was fine!
I can’t find a solution in the internet!
Has anyone a solution??
But I think this is a bug from Nextcloud?!

I can confirm. In 18.0.8 file size (over 2GB) is correct.

In 19 - “pending”
Same in 20.0.0RC2

Please fix

This might be related but also I can’t play videos over 2GB in web video player.
Probably because ow negative size value

Hello, it happens as well to me, with files I think bigger than 4GB.

Have you logged an entry in the Github page for Nextcloud? Maybe there we can get better support than here.

I moved to ubuntu on x86 :slight_smile:

Raspberry pi 3 is too slow for me anyway

I have old tablet with celeron processor 4GB ram and super fast ssd. Nextcloud runs great. It consumes avg 15W.

Perfect solution for small home server. No more issues related to Raspberry PI. No worries about damaged SD card. No more slow responses. And it has built in battery so I can close all applications before turn off.

I wasted 2 days setting Nextcloud on Raspberry Pi 3. No more :slight_smile: