In der Datenbank fehlen einige Indizes

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version :18.0.3
Operating system and version: Ubuntu 18.04.4 LTS (GNU/Linux 4.15.0-54-generic x86_64)
Apache or nginx version : Apache/2.4.29 (Ubuntu)
PHP version:PHP 7.3.16-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Mar 20 2020 13:51:46) ( NTS )

The issue you are facing:
I am getting this alert when logged in as admin:

In der Datenbank fehlen einige Indizes. Auf Grund der Tatsache, dass das Hinzufügen von Indizes in großen Tabellen einige Zeit in Anspruch nehmen kann, wurden diese nicht automatisch erzeugt. Durch das Ausführen von “occ db:add-missing-indices” können die fehlenden Indizes manuell hinzugefügt werden, während die Instanz weiter läuft. Nachdem die Indizes hinzugefügt wurden, sind Anfragen auf die Tabellen normalerweise schneller.

    • Fehlender Index “calendarobject_calid_index” in der Tabelle “oc_calendarobjects_props”.*
    • Fehlender Index “schedulobj_principuri_index” in der Tabelle “oc_schedulingobjects”.

How can I solve this issue using SSH ?

Is this the first time you’ve seen this error? (Y/N): Yes, after updating from 17.0.3 to 18.0.3

Steps to replicate it:

  1. Log in as admin
  2. Go to Settings
  3. Go to overview

The output of your Nextcloud log in Admin > Logging:

PASTE HERE

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Wechsel ins Nextcloud-Verzeichnis, mache die “occ” einmal ausführbar durch Eingabe von “chmod +x ./occ” und führe dann die Datenbank-Operation durch Eingabe von “sudo -u www-data ./occ db:add-missing-indices” aus - das sollte das Problem dann lösen!

@MFGP bitte das nächste mal erst per suchfunktion im forum nachschauen, ob es nicht schon ähnliche fragen/lösungen gibt.
danke.

ps: i.d.r. gibts bei den fehlermeldungen links auf die du klicken kannst. da steht genau was zu tun ist

3 Likes