"in a WebDAV client, use the share token as username and the (optional) share password as password."

I’m trying to [set up Duplicati using webdav on my Nextcloud but I’m spinning my wheels.

Documentation says:

in a WebDAV client, use the share token as username and the (optional) share password as password.

I get the webdav url from settings > webdav in my Nextcloud. I tried to paste it into Duplicati’s input field (Screen below).

When I test the connection I get error message:

Failed to connect: Error: NameResolutionFailure

How can I connect Duplicati to nextcloud? There are advanced options but I’m not sure which I need, if any? What about the documentation blurb above on ‘share token’ and ‘share password’?

image

Some or all of the below information will be requested if it isn't supplied; for fastest response please provide as much as you can :heart:

[/details]

Nextcloud version _(eg, 20.0.5)_: `Hetzners turn key Nextcloud service 'storage share'. 'About' gives version 23.02`
Operating system and version _(eg, Ubuntu 20.04)_: `Not sure?`
Apache or nginx version _(eg, Apache 2.4.25)_:  `Not sure?`
PHP version _(eg, 7.4)_: `Not sure?`

The issue you are facing:
See above

Is this the first time you've seen this error? Y:

Steps to replicate it:

1. Find a webdav client
2. Enter webdav URL, username and password
3. You might get the same error message as above

The output of your Nextcloud log in **Admin > Logging**:

This section seems locked to end users of the storage share product from Hetzner


The output of your config.php file in `/path/to/nextcloud` (make sure you remove any identifiable information!):

Not available to me


The output of your Apache/nginx/system log in `/var/log/____`:

Not available to me

I think your path on server (/home/...) is wrong.
You can read the Nextcloud WebDAV documentation.
I think Dupliciti and WebDAV is not the best combination.

A good alternative to Duplicati is e.g. Nextcloud End-to-End-encryption (video).

1 Like

Thanks for the suggestion, going to try that just now. Here’s my post which led me to duplicati, I was looking for a remote back ups solution similar to deja dup. It looks like NC eee is just the encryption part, not the back up part?

Nextcloud is not really a backup solution. If you sync files between client and server and there is a problem with sync then there is a problem with the “backup”. Also RAID is not a backup for data. For a real backup you need the (incremental) copy of the files on a system you can not reach by stupidity e.g. sync, copy, edit, delete, …

The advantage of Nextcloud 2E2 is the fact that you can activate it only for secure folders. Then you can only access this data from clients. But the other folders are also reachable from e.g. browser. For backup you need a backup of your nextcloud or a backup of your local data at another place. Also you can combine it.

It’s more just to take advantage of the storage provided by Hetzner… I tried removing the ‘path on server’, gave a warning "If you do not enter a path, all files will be stored in the login folder. Are you sure this is what you want? " but then when clicking test I get the same error message " Failed to connect: Error: NameResolutionFailure "

I wonder if the webdav url is ‘wrong’? The url provided in settings > webdav starts with https whereas it looks like expectation is is starts with davs://?

Perhaps the path is . (only a dot) or something else. But on the server i think it is not /home/....

I think the Nextcloud WebDAV is not a really WebDAV. E.g. it includes remote.php. I think that is not WebDAV standard.

Perhaps you can mount webdav in filesystem and then use Dupliciti locally. Read webdav documentation link above. There is an example.

Thanks for the info. Am going to try Hetzner support on this, will update here how I get on.

I think Hetzner support can not help you.

Hi @my_forums_alias_blah

Does the folder and subfolder /home/pop-os already exist on your Nextcloud server? If not create it first and then try the following in Duplicati:

Storage Type: WebDAV
Use SSL:
Server and Port: | cloud.yourdomain.tld | 443 |
Path on server: /remote.php/dav/files/Admin/home/pop-os
Username: Admin
Password: the password of the “Admin” user or the app password if you created one on your Nextcloud.

Thanks for the suggestion. I tried that and got same error :frowning:

The url I used was like this cloud.nx12345.your-storageshare.de/remote.php/dav/files/Admin/. The url provided in settings > webdav is like this https://.nx12345.your-storageshare.de/remote.php/dav/files/Admin/

I set everything else per your suggestion. I also removed /home, it’s just at my nc root I created a directory pop-os and tried with that.

Any more suggestions very welcome!

Found this for you:

Server and port: upload.cloud.website.nl
Remote path: /remote.php/dav/files/username/NAS Backup/Test

https://www.reddit.com/r/NextCloud/comments/i75rdg/how_to_use_duplicati_to_upload_to_nextcloud_webdav/

2 Likes

Did you enter it exactley the way I wrote it in my post?

The field “Server” should only contain the server name, without “https” and slashes

like this…

cloud.nx12345.your-storageshare.com

Port should be obvious:

443

…and then you can enter the rest of the path including the folder you want to store your backups to in to the field “Path on Server” with a slash at the beginning of the path:

/remote.php/dav/files/Admin/Backup-Folder

It is best to create the backup folder manually in the web UI of your Nextcloud first.

1 Like

Progress! I think. I now get a new error message:

Failed to connect: The remote server returned an error: (401) Unauthorized.

So, I think the connection settings are sound now thanks to the info above, but now how do I authorize?!

Thanks for this, seems to be same instructions as b77 gives too and this did work in a sense that I think my connection settings are sound now, but I get a new error ‘unauthorized’ :confused:

To exclude a problem at Hetzner please use a 60 minutes test account at https://try.nextcloud.com

WebDAV (example):
https://demo1.nextcloud.com/remote.php/dav/files/6Sss5eWbdFkmbtbd/
(server is demo1 or demo2)
Username is included in url above
Password is: demo

1 Like

Maybe a silly question, but are both the username and password correct? :wink:

If you have 2FA enabled or if there is some other login method of your provider involved you could maybe set-up a device specific password in your Nextcloud https://docs.nextcloud.com/server/19/user_manual/session_management.html#device-specific-passwords-and-password-changes

1 Like

Aha, yes I do have MFA enabled. Let me read over this link, thank you!

Suspect it’s my MFA settings

Just go to Setings → Personal → Security in your Nextcloud. At the bottom of that page you can click on “Create new app password” and then use that for Duplicati to login.

2 Likes

Thank you!! When I get back to laptop am gonna try this. Will let you know how it goes.

1 Like