Impossible to write NextcloudPi image 3-02-22 to SD Card

Hello,
impossible to copy an image from nextcloudpi Index of /downloads/NextCloudPi_RPi_03-02-22/ to an sd card with balena
I get the error “messing partition table…”
If I copy and ignore the error my raspberry pi 4 doesn’t boot

Thank you for your help

Do you have the same issue with the torrent download?

And did you check the hash-value of the download. Probably there was a package loss in your download.

I downloaded from torrent, several times and tried to put it with several different programs win32, raspberry pi imager and balena
with no result.
Every time there is no boot.
But raspberry pi os, works

--------------edit---------
when i install raspberry pi os on the sd card, it contains 2 partitions, but when i install nextcloudpi, it contains only one

Try re-formatting your sd card, using balena etcher to prepare the image, and making sure ‘boot’ option is ticked using gparted or a similar tool on the card.

If Raspberry Pi OS works fine, you can just run the curl script.

Thank you just

I tried using curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | sudo bash
but the process doesn’t finish properly, (I don’t remember what error). I tried to fix it with the info here 2 Modifications in ncp-dist-upgrade to run successfully · Issue #1460 · nextcloud/nextcloudpi · GitHub without positive result.
I also did an update of the dist. sudo ncp-dist-upgrade, error it doesn’t find dhcpcd.
However my instance works, (not well but works) and I can access the files from outside.

In my opinion the nextcloudpi images contain errors and are not ready to use the latest version of raspberry pi os.
Here is the error in question from Balena:

Capture d’écran 2022-05-02 085506

Envoi en cours : Capture d’écran 2022-05-02 085506.png…

What I recommend to everyone, do not update your system unless you are a computer scientist.

1 Like

Could you please file an issue to Issues · nextcloud/nextcloudpi · GitHub
Include the version of raspberry pi OS you are struggling with, logs, etc. Thanks.

I try to reproduce the issue tonight.
So far I downloaded the torrent and from the website and the checksum was the same.
Did you test the checksum?

Hello
yes, I did the check

Capture d’écran 2022-05-03 090252

I will try to install with a computer on ubuntu

In ubuntu, this works :grinning:

On windows
after decompressing the file NextCloudPi_RPi_03-02-22.tar.bz2 with 7zip, I have the following file with the *.tar extension NextCloudPi_RPi_03-02-22.tar

On ubuntu
after decompression, I get a file with the extension *.img
NextCloudPi_RPi_03-02-22.img

I wonder if this changes anything?

Hey Jeano,
sorry the week is more busy than expected.
I tested the unzipping with windows 10 and winrar.
I also got there an .img file.

I will check as soon as possible to flash it on a SD-card.

That is a correct process for unzipping and untarring the image. It helps if you tell us about those steps (and 7zip) upfront.

It can also be done with a single command supporting tar and bz2. Here is an example:

To use bunzip2 to extract your tar.bz2 file in a single step, use the j switch instead.

    tar xvfj somefilename.tar.bz2

Ahh, nice and simple, just the way we like it.

.img and .iso files are equally usable for writing to an SD Card. Either should work fine.

As mentioned above, on Windows it doesn’t work, maybe it’s because of 7zip.
I will try with winrar…

I just tested, it’s a problem related to 7-zip, I have version 19.
With winrar I don’t get the error

-----edit-------------
with 7-zip version 21, the error persists.

----edit------
I have tested several decompression programs, and the ones that extract the file and *.tar do not work.
on the other hand I found Bandizip (free) it extracts in *.img, with this one there are no problems

Tested with the current 7zip version.
First unzip it to the .tar file. Unzip it once more and you get a folder which includes the .img file.
The .img file has the same size as the winrar unzipped one.
No error occurred while unzipping

That’s right, I did it! Thank you very much for the explanation.