Impossible de se connecter : la page charge sans fin

Bonjour,

Je suis face à un problème dont je ne comprends clairement pas la provenance et face auquel je suis un peu désemparé…
J’espère que quelqu’un ici pourra me montrer le chemin pour résoudre ce souci.

J’utilise NextCloud depuis bientôt un an, je l’ai installé sur un PI 4, et ça fonctionne impeccable, depuis toujours, c’est un logiciel très pratique.

Seulement voilà, il m’arrive un souci.
Quand je vais sur le site, j’ai bien la page /login qui s’affiche.
Mais si je rentre les bons identifiants, la page charge… et ne s’affiche jamais.
Si je rentre les mauvais, la page se recharge bien et m’affiche bien l’erreur.

Dans les logs de nextcloud (nextcloud/data/nextcloud.log), je n’ai pas de message d’erreur.
Et phénomène surprenant, dans les logs d’apache, je vois bien les requêtes POST des essais avec de mauvais login, mais je n’ai pas de requête POST lorsque je rentre les bons login. (!!)

Et bien sûr, ce problème m’arrive aussi bien avec Chrome que Firefox ou Edge, et avec 2 ordinateurs sous Windows 10, ainsi qu’un S7 et une tablette…

Mon installation fonctionnait très bien depuis des mois et des mois.
Je n’ai fait aucun autre modification qu’un “apt upgrade” la semaine dernière, mais depuis j’ai pu me connecter. Le problème semble être apparu hier sans aucune raison apparente.

Si quelqu’un a une piste : je suis preneur :slight_smile:

Mon cloud me manque :frowning:

Bonjour @Toma , avez vous pensez à supprimez les cookies de votre navigateur web ( purger vos cookies provenant de votre page web de votre instance ) ? Il se peut que que ces derniers soit en cause dans le chargement de votre page.

Bonjour Mageunic,
Oui, j’ai essayé mais malheureusement cela ne change rien.
J’ai d’autres sous domaines sur le même serveur Apache, et ils fonctionnent tous très bien.

Ok, j’ai résolu ce problème : Merci Mageunic !

Je n’avais cherché les logs de nextcloud, que dans le fichier data/nextcloud.log.
J’y trouvai d’ailleurs les “Login failed” que j’avais provoqué en testant.

php occ log:tail

Et donc, j’ai été surpris de découvrir d’autres messages avec cette commande !
Notamment ce message :

Error core Following symlinks is not allowed (’/some/random/sub/folder/’ -> ‘/some/other/’ not inside ‘/some/random/’)

J’avais donc un lien symbolique, dans le dossier de partage, qui pointait vers un dossier qui n’est pas dans le dossier de partage :crazy_face:
Et cette erreur est tellement fatale, que nextcloud ne permettait même pas à Apache de simplement écrire le log de la requête POST /login avec un erreur 500, par exemple. :crazy_face:
J’ai l’impression que cette erreur provoque un genre de boucle infinie qu fait freezer nextcloud.

Bref, j’ai viré ce lien symbolique, et ça re-marche niquel :sunglasses:

1 Like