Impersonate not working (for me) after last update


I am a Nextcloud administrator for a small company and I’ve been using impersonate’s app since I discovered it. It’s been very useful to fix users’ accounts and manage “global” accounts.

But since last update it have stopped working for me. Incarnate button have been moved to the end of the row and now it’s a submenu: Deactivate, Remove and Impersonate are all the options in that submenu. Deactivate and Remove account work as expected when I click on them, but Impersonate does nothing.

I have tried Firefox 59 and Edge, with same results: when I click on Impersonate nothing happens.

Someone with the same problem? It’s only me?

And please, move Impersonate button to the beginning of the row as previous version was. The end of the row usually is outside of the right margin of the screen and when scrolling to the right you can’t see which user you are going to impersonate and I have to double check left and right :frowning:

New info: When I click on the Impersonate button to open it in a new tab, this page is opened:, which is just the users administration page with a # at the end of the URL. It does nothing besides reloading the user administration page in another tab :frowning_face:


I am also having this issue. all it does in refresh the current page it appears. I am using chrome with same result.


Nextcloud version :
Firefox ESR 52.7
Impersonate 1.0.3

Same issue too after update impersonate from 1.0.2 to 1.03. I try to disable/remove and reinstall impersonate app whitout success.

Problem has been solved for me after nextcloud update to 13.0.1.
Impersonate app work now as expected.