Im about to give up... the dreaded .ocdata

Nextcloud version _21 something
Operating system and version _(eg, Ubuntu 20.04) yep
Apache or nginx version (eg, Apache 2.4.25): nope snap install
PHP version (eg, 7.4): snap install

The issue you are facing:
lets boil it down… I hear how great this program is, but can NEVER get it to fully work, docker… nope! long drawn out add this then this before you do this do the freaking hokey pokey and sacrifice two minions to the gods of computing… nope. hired guy at $100 bucks an hour … NOPE! so my server hdd crashed, as I lament my woes to my buddy he says hey I just installed it using snap super easy. so i’m putting up a new build anyways… whats it going to hurt… I try snap and angels are singing heavens shining down IT WORKS!

it works you say… so why are you about to give up??? well… it did work. here’s the deal. it’s on a little itty bitty 120gig drive i maintain pretty much solely for OS. I have 2 x 10 terra disk pools sitting for stuff like photos and media and well… everything (whisper repeating everything). so i read though a few how to on designating the drive you want. simple enough I make edits copy shut it down restart… and I get the dreaded error… that’s if it runs at all. I have tried checking permissions setting ownership enabling and disabling in stead of start and stopping, cp -a cp -avf cp -sacrifice_two_lama’s everything that I have searched here and on the web… no dice. Fine… we’ll try a 2 tb usb external drive… set everything back to normal it works again, but nextcloud will not show the usb drive. I can access it through the server and samba files into it from other computers… nextcloud… nope! i either dont have a drive or permissions. I am ROOT you infernal program! ok ok ok… we’ll pull the 2 tb out of the usb device and use that to run my server. haha you fool says nextcloud!

so now I’m back to where i started… my curtains have caught fire from the sacrificial candles, the carcasses’ of sacrificed beings piled to the ceiling… I can run nextcloud, but seemingly only on the little 120 gig.

please… anything you can advise … it seems like its exactly what I have been looking for but simply refuses to work as I need it to.

thanks… and hopefully you find some humor in my frustrations.

Try reading and following the documentation. That will be much easier, along with posting specific technical details of what you are trying to fix. Good luck.

That’s your problem, you’re obviously not reading the docs. To use the snap requires THREE llamas.

In all seriousness, I’m afraid I’m not entirely clear what your problem is. I’m happy to help but I need some clarification. Are you just trying to get the snap to put its data on another drive? That process is documented here, if it’s helpful. Just read carefully, you need to connect the removable-media plug to grant access, AND make sure your drive is mounted in /mnt/ or /media/ somewhere so it’s available while under confinement. I’m available if you need some synchronous help.

1 Like

thanks. sorry my frustrations were running away with me.

yes I am trying to get the snap to place data on another drive. I’ll read through the documented process you linked. and let you know if it gets me any further. at this point after a few days of trying to resolve the issue, I’m not entirely sure which ones I haven’t done anymore… i thought I had thoroughly tried them all before posting.

thanks again… third lama being wrangled now

thanks, sorry my frustrations were running away with me. the comment below yours has a snap specific document I will try that first, and if I am still having issues after both I’ll try to leave the artistic flair off

must have been that third lama… :slight_smile: or maybe just wipe and go real slow through the document you suggested. finally have a few tb instead of a few gb to store my files on. thank you very much

1 Like