I made a big mess

I had a perfectly funtioning NC24 instance, but wished to upgrade because 24 was out of support. After some strife about permissions, I got it to go to 25 through the web updater (the command line one wanted to got to 27, not allowed) but then after a few days it started putting itself in maintenance mode for no obvious reason. That’s a bug I had seen in the forums, so I figured I’d upgrade to 26. But that required some other changes first. I was on Ubuntu 20 and php7.4 so I first did the Ubuntu upgrade to 22.

That went smoothly…and broke everything. Apache wouldn’t start due to a certificate issue. The upgrade uninstalled php7.4 and didn’t replace it with anything, so I had to upgrade to php8.1 myself and transfer the configuration. I think those two are happy now. Neither log shows any errors since I reconfigured them. I had to manually upgrade from pgsql 12 to pgsql 14, which I believe I have done successfully. The database is live, accessible, and apparently working. I reset the password for ncadmin in pgsql to update to the new algorithm.

But it still doesn’t work. The nextcloud GUI will not load. Internal server error. I am running out of places to look, and wonder if anyone here has any suggestions. The nextcloud log is singularly unhelpful, containing endless “tried to access array offset on value of type null” messages. Frustratingly, it’s not showing any new entries at all. After I corrected the issues with php, apache, and pgsql it looks from the logs like everything is working. But nothing does.

Any ideas? Any other logs to check that I’ve failed to notice? I have a good backup, but would hate to have to fall back to that. I feel like I’m minutes from a running instance if I only knew what to check next. My linux admin skills are marginal at best, and I have searched and tried without resolving the issue. It’s really frustrating.

Someone more familiar with this rascal under the hood care to help?

I just saw this. This is a very similar sounding thing, except that I’m not seeing the same errors. The nextcloud log file he references doesn’t exist on mine.

In the end, the issue turned out to be that the Apache2 php8.1 module wasn’t installed. I loaded that and it was off to the races. Gracious. Now I’m off to bed minus 4 hours of sleep that this struggle cost.