I have looked everywhere but I can't sync the calendar with Win 10

Hey guys,
I’m new here and I’ve searched at several sites but found just nearly the same explanation at these several websites which doesn’t work for me. I’ve created an icloud-account and replaced the caldav-adress but the calender-app shows up “Calendars cannot be retrieved”.
I tried to sync via local network - the ssl certificat is selfsigned and the sync (same method) works with an iphone.

I dropped the Windows default calendar app. So much sh*t to do for a non working sync…
i use outlook or thunderbird for viewing my calendar.

Indeed iOS works well because it implement correctly CardDav and CalDav

It worked for me. Windows calendar app. Create new isync calenders. Edit the name and login (use your NC username and password). Scroll to the bottom and add the caldav adress at the right place. Save and wait. After some minutes the synced calenders appear. And it works better than the built in.

I did exactly this but it doesn’t work … I have reseted the app - nothing

the outlook sync works fine but I don’t want to start outlook every time I just want to have a quick look at my calendar

To be clear - we are talking about the “Mail and Calendar for Windows 10 app” https://www.microsoft.com/en-us/p/mail-and-calendar/9wzdncrfhvqm?activetab=pivot:overviewtab

and you do follow this

It works for me. Where do you get stuck?

yea we are talking about the same app
and I did the same steps as discribed

But nothing happens after I have been following the instructions - no sync and when I open up the account-settings I see the error description “Calendars cannot be retrieved” (picture attached [german])
Maybe anyone can help me to get to know more about this error …

Ah and I don’t use a two-factor authentication

I tried to setup the app with another pc (where the windows-app wasn’t set up before - so there couldn’t any compromises because of old tryings to setup an account) but I got the same error-message.

So it seems to be an “nextcloud-error” … does anyone know how to get to know more about this error?
please help me! :sob::scream:

So no one can help me? :disappointed_relieved:

maybe it’s more like a self-signed certificate-error. since my installation runs and connects without any flaws…

but well… on the other hand: you haven’t told anything about your server, settings, config, environment etc… so it could be everything

what information would be helpfull? I mean I can’t post every single file of my system and I don’t know what files / settings are interessting for this error
nextcloud is installed on an ubuntu system and runs with apache 2 the https - certificate is self signed (and there is no alternative to encryption the traffic within the own network [as far as I know] …)

I don’t know how to get to know more about the error … and so I don’t know what information would be helpful …

so you claim that everything was done the way it got suggested… and it still doesn’t work.
the only thing you don’t have seems to be an official ssl— you use a selfsigned one. so THIS sounds like THE problem to me.
some apps/softwares don’t like those.

as for your questions where to look?
what about app issue template?
or nextcloud.log?

Ok, I have tried to figure out how to configure my apache and nexcloud server to use ssl just for an external conection - but I didn’t find anything
So is it possible do “ignore” the ssl encryption in case the request comes from the local network?
So that the connection is encrypted if I try to connect via Internet?

Of course, that would be possible (while not advisable), but the Windows App seems too dumb for that. Probably there’s no way around a proper certificate if you want to use that Windows app. For luck, there’s LetsEncrypt, which gives you certificates for free :slight_smile: You only need a domain name for your server to be reachable from the outside.

1 Like

So there is no way to synchronize the Windows app via home network.?
Cause I can use LetsEncrypt to create certificates just for proper web-servers. (right?)
So I have to setup the Windows app so that it starts to send a request from my own network out of it to a web-server which connect to my Nextcloud-Server at my own network… :face_with_raised_eyebrow: :unamused:
So I send a request halfway across the world to connect two pcs which are one meter apart.

Ok … than I have to waite to test this because my provider is incompetent to set a public ip…

But why is it not advisable not to encrypt the communication inside the own network? It shouldn’t be a problem if the network is secured properly, should it?

And is there a more elegant way to secure the intern network communication than to create self-signed certificates?

No just do the following :
Install real letsencrypt ssl cert on your nextcloud server
On your home local windows machine modify the C:\Windows\System32\drivers\etc\hosts file with add the line
Your local nextcloud server ip Your domain name
Exemple cloud.mydomain.fr

Like this the windows computer will accept this nextcloud instance with HTTPS while connecting it on local