I get error when assembling chunks, status code 500

I use a hosting service that gives me unlimited storage, and I decided to install nextcloud on it as i love the app and everything about it.
However, whenever I try to upload large files I get the error, “Error when assembling chunks, status code 500”, after completion of the upload, and the file is never uploaded. It seems I cant upload anything larger than 500mb otherwise i will get that error.

I use my laptop’s browser to upload, i’ve changed browsers, i’ve changed laptops, i’ve changed wifis but i still get the same problems.

Mysql Version is 5.7.37
Size = 2.7mb

Then the server that the system is installed on is:
Linux 4.18.0
CPU:
AMD EPYC 750P 32-core processor
Memory 125.51 GB.

Please help
Thank you in advance

Below is the code from my htaccess file:

SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1 SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION # Add security and privacy related headers
# Avoid doubled headers by unsetting headers in "onsuccess" table,
# then add headers to "always" table: https://github.com/nextcloud/server/pull/19002
Header onsuccess unset Referrer-Policy
Header always set Referrer-Policy "no-referrer"

Header onsuccess unset X-Content-Type-Options
Header always set X-Content-Type-Options "nosniff"

Header onsuccess unset X-Frame-Options
Header always set X-Frame-Options "SAMEORIGIN"

Header onsuccess unset X-Permitted-Cross-Domain-Policies
Header always set X-Permitted-Cross-Domain-Policies "none"

Header onsuccess unset X-Robots-Tag
Header always set X-Robots-Tag "none"

Header onsuccess unset X-XSS-Protection
Header always set X-XSS-Protection "1; mode=block"

SetEnv modHeadersAvailable true

Add cache control for static resources

<FilesMatch “.(css|js|svg|gif|png|jpg|ico|wasm|tflite)$”>
Header set Cache-Control “max-age=15778463”

<FilesMatch “.(css|js|svg|gif|png|jpg|ico|wasm|tflite)(?v=.*)?$”>
Header set Cache-Control “max-age=15778463, immutable”

Let browsers cache WOFF files for a week

<FilesMatch “.woff2?$”>
Header set Cache-Control “max-age=604800”

PHP 7.x

php_value mbstring.func_overload 0 php_value default_charset 'UTF-8' php_value output_buffering 0 SetEnv htaccessWorking true

PHP 8+

php_value mbstring.func_overload 0 php_value default_charset 'UTF-8' php_value output_buffering 0 SetEnv htaccessWorking true AddType image/svg+xml svg svgz AddType application/wasm wasm AddEncoding gzip svgz DirectoryIndex index.php index.html ModPagespeed Off RewriteEngine on RewriteCond %{HTTP_USER_AGENT} DavClnt RewriteRule ^$ /remote.php/webdav/ [L,R=302] RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}] RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L] RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L] RewriteRule ^remote/(.*) remote.php [QSA,L] RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L] RewriteRule ^\.well-known/(?!acme-challenge|pki-validation) /index.php [QSA,L] RewriteRule ^(?:\.(?!well-known)|autotest|occ|issue|indie|db_|console).* - [R=404,L]

AddDefaultCharset utf-8
Options -Indexes

DO NOT CHANGE ANYTHING ABOVE THIS LINE

php_value upload_max_filesize 9000000G
php_value post_max_size 200000M
php_value memory_limit 9000000G
php_value max_execution_time 64000000
php_value max_input_time 64000000

ErrorDocument 403 /
ErrorDocument 404 /