I can't use Collabora anymore because Docker won't run

Based on the lack of results while searching for solutions here, I may be the only person with this particular problem. (#EdgeCase)

Somewhere about a week ago I discovered the Collabora wasn’t working. As I got further down the troubleshooting road, I discovered that Docker wasn’t running. I went through the standard hack-admin tricks of duck-duck-go’ing the error messages seen in,
—> See "systemctl status docker.service" and "journalctl -xe" for details.,
in a variety of ways, but the results never produced a solution to my problem.

I’ve tried a few ways of removing and reinstalling Docker by following the page here:

Every attempt I have made (about 8 permutations), has always failed to finish properly because the docker never starts.

Does anybody want to guess how I may have loused things up?

sudo apt-get install docker-ce docker-ce-cli containerd.io
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  docker-ce-rootless-extras docker-scan-plugin pigz
Suggested packages:
  aufs-tools cgroupfs-mount | cgroup-lite
Recommended packages:
  slirp4netns
The following NEW packages will be installed:
  containerd.io docker-ce docker-ce-cli docker-ce-rootless-extras docker-scan-plugin pigz
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/108 MB of archives.
After this operation, 465 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
[master a7b6a95] saving uncommitted changes in /etc prior to apt run
 Author: shitadmin <shitadmin@srv9>
 2 files changed, 2 deletions(-)
Selecting previously unselected package pigz.
(Reading database ... 324318 files and directories currently installed.)
Preparing to unpack .../0-pigz_2.4-1_amd64.deb ...
Unpacking pigz (2.4-1) ...
Selecting previously unselected package containerd.io.
Preparing to unpack .../1-containerd.io_1.4.6-1_amd64.deb ...
Unpacking containerd.io (1.4.6-1) ...
Selecting previously unselected package docker-ce-cli.
Preparing to unpack .../2-docker-ce-cli_5%3a20.10.7~3-0~ubuntu-bionic_amd64.deb ...
Unpacking docker-ce-cli (5:20.10.7~3-0~ubuntu-bionic) ...
Selecting previously unselected package docker-ce.
Preparing to unpack .../3-docker-ce_5%3a20.10.7~3-0~ubuntu-bionic_amd64.deb ...
Unpacking docker-ce (5:20.10.7~3-0~ubuntu-bionic) ...
Selecting previously unselected package docker-ce-rootless-extras.
Preparing to unpack .../4-docker-ce-rootless-extras_5%3a20.10.7~3-0~ubuntu-bionic_amd64.deb ...
Unpacking docker-ce-rootless-extras (5:20.10.7~3-0~ubuntu-bionic) ...
Selecting previously unselected package docker-scan-plugin.
Preparing to unpack .../5-docker-scan-plugin_0.8.0~ubuntu-bionic_amd64.deb ...
Unpacking docker-scan-plugin (0.8.0~ubuntu-bionic) ...
Setting up containerd.io (1.4.6-1) ...
Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service → /lib/systemd/system/containerd.service.
Setting up docker-ce-rootless-extras (5:20.10.7~3-0~ubuntu-bionic) ...
Setting up docker-scan-plugin (0.8.0~ubuntu-bionic) ...
Setting up docker-ce-cli (5:20.10.7~3-0~ubuntu-bionic) ...
Setting up pigz (2.4-1) ...
Setting up docker-ce (5:20.10.7~3-0~ubuntu-bionic) ...
Created symlink /etc/systemd/system/multi-user.target.wants/docker.service → /lib/systemd/system/docker.service.
Created symlink /etc/systemd/system/sockets.target.wants/docker.socket → /lib/systemd/system/docker.socket.
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Thu 2021-06-24 15:31:46 EDT; 12ms ago
     Docs: https://docs.docker.com
  Process: 18281 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock (code=exited, status=1/FAILURE)
 Main PID: 18281 (code=exited, status=1/FAILURE)
dpkg: error processing package docker-ce (--configure):
 installed docker-ce package post-installation script subprocess returned error exit status 1
Processing triggers for systemd (237-3ubuntu10.48) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for ureadahead (0.100.0-21) ...
Errors were encountered while processing:
 docker-ce
[master 8a81a59] committing changes in /etc after apt run
 Author: shitadmin <shitadmin@srv9>
 15 files changed, 294 insertions(+)
 create mode 100644 containerd/config.toml
 create mode 100644 default/docker
 create mode 100755 init.d/docker
 create mode 100644 init/docker.conf
 create mode 120000 rc0.d/K01docker
 create mode 120000 rc1.d/K01docker
 create mode 120000 rc2.d/S01docker
 create mode 120000 rc3.d/S01docker
 create mode 120000 rc4.d/S01docker
 create mode 120000 rc5.d/S01docker
 create mode 120000 rc6.d/K01docker
 create mode 120000 systemd/system/multi-user.target.wants/containerd.service
 create mode 120000 systemd/system/multi-user.target.wants/docker.service
 create mode 120000 systemd/system/sockets.target.wants/docker.socket
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anybody? … Anybody?

Beuller? … Beuller? … Beuller? … Beuller? … Beuller? … Beuller?

your docker socket is running?

systemctl status docker.socket

stopped working / never worked?

don’t know what went wrong, but obviously docker isn’t installed proberly.

did you try to remove/purge the existing installation?

Unit docker.socket could not be found.
I’m currently in the uninstalled state. No attempts to install it were successful since about a month ago. I could try again if you have a sure fire script of commands to do it.

Definitely stopped working. I was doing Colabora since years ago. I may have started in NC version 12?

Yes, I did.

it might or might not be related: Deinstall and install of docker ce fails on ubuntu 18.04 · Issue #41792 · moby/moby · GitHub but there seems to exist some problems installing docker on ubuntu.