I can't upload new app release to the app store

When I try to upload a new app release by clicking the “Upload” button, the page looks like it’s loading but then it stops as if nothing happened. The new release doesn’t get uploaded.

The browser console shows: 500 Internal Server Error.

Uploading new app releases was working fine 4 days ago. I noticed that the ‘Upload app release’ page has a new CSS look now but its functionality seems to have problems.

cc @carlschwan @blizzz

It suppose it is this error i found in the logs:

KeyError: “filename ‘sms_relentless/Telnyx/vendor/squizlabs/php_codesniffer/src/Standards/Generic/Tests/ControlStructures/’ not found”

So an expected file is not there. Perhaps try to repackage without dev dependencies?

@blizzz I repackaged the application without the test files that might have caused the error. In the ControlStructures directory that you mention above there is now one single regular file. Yet, the same behavior. The app can’t be uploaded and the browser console shows 500 Internal Server Error.

Why 4 days ago I was able to upload the same app without any complaints about the ControlStructures directory and now I cannot ? I think the changes to the upload scripts that you have implemented recently cause the problem. Otherwise I can’t explain why the ControlStructures directory was accepted 4 days ago and many more times in the previous app versions, and now it isn’t. Also, you didn’t say what file in this directory was found missing. Originally, there are 13 files in this directory.

@blizzz I just repackaged the app again removing all the dev dependencies and the same result. The app can’t be uploaded. The same 500 Internal Server Error I’m sure it’s a problem with the recent changes to the uploading page/script and my app doesn’t have any problems. I think no other apps can be uploaded.

Please consider reverting to the old uploading process which was working so fine 4 days ago and for as long as I can remember, since I never faced this issue before.

Please tell me if somebody is working to solve this problem. For me it’s very important to upload the new app version today.

Releasing works, there have been recent uploads.

I bet you need to update the signatures (appinfo/signature.json).

@blizzz No, it’s not the appinfo/signature.json. I repackaged the app without the dev dependencies and even without Composer multiple times, removing all unnecessary files from the helper libraries of Telnyx and Twilio and each time I took care to sign the app.

I tried to upload the new version of a different app that I develop, to test if it works and indeed it worked, therefore, uploading new app releases works and it’s not a problem with my IP/browser, etc. It has to be something with the Twilio library, because it’s the only thing that I added to my application since the last version. The other changes were minor code changes to already existing files.

I downloaded Twilio’s library from their official GitHub repository What does the uploading script find so odd about this library ?

I need your help on this. Please tell me what is the error in the server logs when the upload fails !

The other error that you mentioned above cannot happen again because the dev dependencies, including that directory, were removed entirely.

The latest error I spot is:

KeyError: "filename 'sms_relentless/providers/Twilio/src/Twilio/Rest/Serverless/V1/Service/TwilioFunction/FunctionVersion/' not found"

I finally solved it.

It turned out that Twilio’s helper library contained some files that were identified by the uploading script as dubious. The solution was to simply remove the entire library and make all the API requests directly, using curl and GET requests. This way I was able to upload the new app version to the Nextcloud app store.

Thank you blizzz and szaimen for your help. Nextcloud is much appreciated and needed by so many people.